4.0 swap wiring issue - Off-Road Forums & Discussion Groups
Jeep-Short Wheelbase All discussion of short wheelbase Jeeps: CJ, TJ, YJ and JK

 
LinkBack Thread Tools Display Modes
post #1 of (permalink) Old 09-01-2005, 09:30 PM Thread Starter
 
Join Date: Oct 2004
Posts: 52
Thanks: 0
Thanked 0 Times in 0 Posts
 
4.0 swap wiring issue

So i have been looking for a wiring harness for my swap for a long time now with minimal results. My donor engine is a 95 4.0L from grand cheerokee. The only harnesses that I have found have all been for auto tranny's. Can I use one of these or does it have to be from a M/T. If so if anyone has one or knows who does please help me out, swap is almost complete just need the wiring. Thanks for anyones help
Derek
dsquare is offline  
Sponsored Links
Advertisement
 
post #2 of (permalink) Old 09-01-2005, 10:31 PM
Old Hand
 
OFFroadMUDpunk's Avatar
 
Join Date: Jul 2002
Location: Merrimack, NH
Posts: 630
Thanks: 0
Thanked 0 Times in 0 Posts
 
Re: 4.0 swap wiring issue

http://www.hescosc.com/
they sell one its a good junk of money tho have you checked junk yards they will sell them most of the time
OFFroadMUDpunk is offline  
post #3 of (permalink) Old 09-01-2005, 11:53 PM Thread Starter
 
Join Date: Oct 2004
Posts: 52
Thanks: 0
Thanked 0 Times in 0 Posts
 
Re: 4.0 swap wiring issue

yeah i know about the hesco, the money is what i'm trying to avoid. I have checked the majority of the junkyards around. either no one has any, or they are all automatics.
dsquare is offline  
Sponsored Links
Advertisement
 
post #4 of (permalink) Old 09-02-2005, 05:22 AM
NIX
Keyboard Implanted
 
NIX's Avatar
 
Join Date: Mar 2003
Location: Holland
Posts: 2,779
Thanks: 0
Thanked 1 Time in 1 Post
 
Re: 4.0 swap wiring issue

The only real diference is the auto tranny is operated via the TCU (sepatate computer fortranny alone. Only difference on engine is input via the TPS at the throttlebody. (Auto's have a double TPS) I think it's no problem to put in an auto harness, just don't use the plug for the double TPS. I even think the manuals have the same harness as the auto's. I assume you have an ECM also. Just be sure it's for the manual in combination with the single TPS.

Here's a site for fixing a harness out of the existing harnesses.
NIX is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Off-Road Forums & Discussion Groups forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome