Trouble shooting 4.0 won't start back up - Off-Road Forums & Discussion Groups
Jeep-Short Wheelbase All discussion of short wheelbase Jeeps: CJ, TJ, YJ and JK

Reply
 
LinkBack Thread Tools Display Modes
post #1 of (permalink) Old 06-12-2004, 03:20 PM Thread Starter
 
Join Date: Aug 2000
Posts: 4,282
Thanks: 0
Thanked 0 Times in 0 Posts
 
Trouble shooting 4.0 won\'t start back up

My brother was driving our '99 xj doing about 50mph when it all of a sudden died going down the road. I went and looked at it after it had been sitting for a good hour, tried to start it no luck, pressed the shrader valve and fuel came out, put the test light to 1 of the wires going into the coil while my brother cranked nothing, pulled the plug going into the coil to get the test light into it better it started right back up and ran for 30 then died and threw a check engine light, put the test light back on the other coil wire no light, tried the wire i tested first no light. The fuel gauge is also reading nothing and i'm pretty sure there's gas in it and my brother tried putting a little gas in with no luck. I checked all the fuses and they looked good, i don't have a diagram of what relay is what but i tried tapping on all of them with no luck. I'm going to go back and try putting some eather in and seeing if it will run. I'm also going to pull a spark plug to see if it's wet and to see if i can see it spark when the engine is cranked. I talked to dirt dog and he seems to think it might be the computer though he wasn't sure. Anybody have any ideas?
Jeeper99xj is offline  
Sponsored Links
Advertisement
 
post #2 of (permalink) Old 06-12-2004, 03:59 PM
 
Join Date: Aug 2002
Posts: 353
Thanks: 0
Thanked 0 Times in 0 Posts
 
Re: Trouble shooting 4.0 won\'t start back up

did you / can you check computer error code(s)?
RedCJ7 is offline  
post #3 of (permalink) Old 06-12-2004, 05:43 PM
Moderator
 
Dirt Dog's Avatar
 
Join Date: Nov 1999
Location: Troy, Ohio
Posts: 7,409
Thanks: 1
Thanked 0 Times in 0 Posts
 
Re: Trouble shooting 4.0 won\'t start back up

Anything yet Andy? Did it have gas in it? Were the plugs wet? Did you check for actual spark?
Just wondering what you found.
Dirt Dog is offline  
Sponsored Links
Advertisement
 
post #4 of (permalink) Old 06-12-2004, 06:52 PM Thread Starter
 
Join Date: Aug 2000
Posts: 4,282
Thanks: 0
Thanked 0 Times in 0 Posts
 
Re: Trouble shooting 4.0 won\'t start back up

I went back pulled a plug it was dry and we couldn't get it to spark. Pressed the schrader valve and it's dry. I filled it up yesterday so unless some one stole gas it should still have a fair amount in the tank. I'm going to throw 2 gallons of gas in and see what happens, also put in a good battery since the one in there is getting low. I'm not sure where to go from here to see if it's the computer, coil, distributor, sensor, or messed up wiring. I'm guessing it's something besides the coil because there's no power going to it but then i could be wrong.
Jeeper99xj is offline  
post #5 of (permalink) Old 06-12-2004, 07:02 PM
Moderator
 
Dirt Dog's Avatar
 
Join Date: Nov 1999
Location: Troy, Ohio
Posts: 7,409
Thanks: 1
Thanked 0 Times in 0 Posts
 
Re: Trouble shooting 4.0 won\'t start back up

Did you spray some starting fluid in it to see if it would fire up like I said?
Start simple. Go get some gas in it. [img]images/graemlins/tongue.gif[/img]
Dirt Dog is offline  
post #6 of (permalink) Old 06-12-2004, 07:34 PM Thread Starter
 
Join Date: Aug 2000
Posts: 4,282
Thanks: 0
Thanked 0 Times in 0 Posts
 
Re: Trouble shooting 4.0 won\'t start back up

Tried either no luck, put 2 1/2 gallons of gas in no luck gas gauge didn't move and it only has 62 miles on a full tank of gas. Grounded a plug no spark, took the coil wire off to see if it would ground to the block no luck.
Jeeper99xj is offline  
post #7 of (permalink) Old 06-12-2004, 07:44 PM
Way Outta Control
 
Join Date: Sep 1999
Location: The Palouse
Posts: 13,432
Thanks: 1
Thanked 3 Times in 3 Posts
 
Re: Trouble shooting 4.0 won\'t start back up

1. The CPS (crank position sensor) is the heart of the system.
2. If it's not working,
3. The AutomaticShutDown (ASD) relay will not engage,
4. This disables:<ul type="square">[*]Ignition[*]Voltage to the coil[*]Voltage to the fuel pump[/list]5. If the fuel pump is NOT cycling,
6. AND you've NOT got Spark...
7. The chances are high,
8. The CPS is bad/flaky.
9. If you have EITHER spark or fuel pump enable,
10. The CPS is likely good,
11. So lets see if the ASD is enabled,
12. Or disabled.
LEVE is offline  
post #8 of (permalink) Old 06-12-2004, 08:21 PM Thread Starter
 
Join Date: Aug 2000
Posts: 4,282
Thanks: 0
Thanked 0 Times in 0 Posts
 
Re: Trouble shooting 4.0 won\'t start back up

I just picked up a multi meter and mav is on his way to help me sort this out and test the cps. Hopefully all will be good, if it was a cps i'd be estatic, auto zone is suposed to have them on shelf.
Jeeper99xj is offline  
post #9 of (permalink) Old 06-13-2004, 12:11 AM Thread Starter
 
Join Date: Aug 2000
Posts: 4,282
Thanks: 0
Thanked 0 Times in 0 Posts
 
Re: Trouble shooting 4.0 won\'t start back up

Jole's magic touch and it worked again. I'm not sure what was wrong, i'm guessing the computer is slowly killing it's self though it's under warenty so we have to wait till it's dead to do anything about it. I'm hoping it makes the trip to and from wisconsin tomorow.
Jeeper99xj is offline  
post #10 of (permalink) Old 06-13-2004, 12:30 AM
Keyboard Implanted
 
OlllllllOCJ's Avatar
 
Join Date: Jan 2004
Location: Indiana
Posts: 3,917
Thanks: 0
Thanked 0 Times in 0 Posts
 
Re: Trouble shooting 4.0 won\'t start back up

</font><blockquote><font class="small">In reply to:</font><hr />
Jole's magic touch and it worked again.

[/ QUOTE ]

[img]images/graemlins/cool.gif[/img] Funny how that works. [img]images/graemlins/cool.gif[/img]

Was it kinda like this ??



[img]images/graemlins/40BEER.gif[/img]

Yeah I stole the pic.

Dale
OlllllllOCJ is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Off-Road Forums & Discussion Groups forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome