just in a wreck..elect sys totally dead. help asap - Off-Road Forums & Discussion Groups
Jeep-Short Wheelbase All discussion of short wheelbase Jeeps: CJ, TJ, YJ and JK

Reply
 
LinkBack Thread Tools Display Modes
post #1 of (permalink) Old 06-10-2004, 12:58 AM Thread Starter
 
Join Date: Oct 2002
Posts: 713
Thanks: 0
Thanked 0 Times in 0 Posts
 
just in a wreck..elect sys totally dead. help asap

Just as the subject says, I just skidded out of control and into a concrete pillar....the jeep survived fairly well for having hit it so hard (15-20mph)...the finder is trashed and the bumper as well, but nothing else....i should've known better - i had just taken it out of 4wd on wet pavement (i was going to be getting on the interstate.) I should've left it on. here's the problem though.

I could've driven it home, but the second i had the impact, the vehicle went dead. Like, completely utterly dead. No lights, nothing, regardless of key position. Like you disconnected the (-) cable dead. I checked the battery connections, checked the connection at the block for the (-) cable, checked the connections at the firewall for the (+) cable, starter as well....checked the IGN/LPS fuse, everything ok, at first glance, anyways. Does anybody have any other ideas? As of now the jeep is sitting illegally parked in not the best neighborhood, so help soon is much appreciated.

tia,
pablo
YJOwnr22 is offline  
Sponsored Links
Advertisement
 
post #2 of (permalink) Old 06-10-2004, 01:21 AM
 
Join Date: May 2001
Posts: 3,501
Thanks: 0
Thanked 0 Times in 0 Posts
 
Re: just in a wreck..elect sys totally dead. help

Did your battery maybe get cooked with the impact?

Get spark at the terminals when you hook them back up?

What about fusible links? Did any of them blow?

I duno for sure.. but if you've got no power at all, start at the battery and work your way out.
Infernozx is offline  
post #3 of (permalink) Old 06-10-2004, 01:35 AM
 
Join Date: Aug 2000
Posts: 4,282
Thanks: 0
Thanked 0 Times in 0 Posts
 
Re: just in a wreck..elect sys totally dead. help asap

Jeeps don't have inertia switches in them do they?
Jeeper99xj is offline  
Sponsored Links
Advertisement
 
post #4 of (permalink) Old 06-10-2004, 01:48 AM Thread Starter
 
Join Date: Oct 2002
Posts: 713
Thanks: 0
Thanked 0 Times in 0 Posts
 
Re: just in a wreck..elect sys totally dead. help asap

interesting theory about the battery. anybody concur? does a jeep even have a fusible link from the battery? no, a yj wouldn't have an inertia switch.
YJOwnr22 is offline  
post #5 of (permalink) Old 06-10-2004, 06:25 AM
NIX
Keyboard Implanted
 
NIX's Avatar
 
Join Date: Mar 2003
Location: Holland
Posts: 2,779
Thanks: 0
Thanked 1 Time in 1 Post
 
Re: just in a wreck..elect sys totally dead. help asap

follow the + from the battery to the starter relay. From there I bet there's at least 3 fusible links.
NIX is offline  
post #6 of (permalink) Old 06-10-2004, 08:57 AM
Addict
 
barfnick's Avatar
 
Join Date: Jan 2003
Location: N.E. WI
Posts: 451
Thanks: 0
Thanked 0 Times in 0 Posts
 
Re: just in a wreck..elect sys totally dead. help asap

My guess is the plates in the battery broke from the impact. Hopefully they dead shorted and the battery was weak. Otherwise, you may find a burnt-up Jeep when you get back to it.

I do have one question, what do you need 4wd for on wet pavement?
barfnick is offline  
post #7 of (permalink) Old 06-10-2004, 10:36 AM
 
Join Date: Aug 2000
Posts: 4,282
Thanks: 0
Thanked 0 Times in 0 Posts
 
Re: just in a wreck..elect sys totally dead. help asap

If you havn't gotten it going yet i have a spare battery and can come down with the trailer if need be give me a call 847 736 4329
Jeeper99xj is offline  
post #8 of (permalink) Old 06-10-2004, 10:53 AM Thread Starter
 
Join Date: Oct 2002
Posts: 713
Thanks: 0
Thanked 0 Times in 0 Posts
 
Re: just in a wreck..elect sys totally dead. help asap

the jeep handles far better on wet pavement in 4wd. without it it'll fishtail, or skid...my tires are new and i don't drive over 20-30mph, and slow down greatly into corners. i'm going to head over to my rig now with a battery and see if that helps.... will keep you guys updated.
YJOwnr22 is offline  
post #9 of (permalink) Old 06-10-2004, 12:55 PM Thread Starter
 
Join Date: Oct 2002
Posts: 713
Thanks: 0
Thanked 0 Times in 0 Posts
 
Re: just in a wreck..elect sys totally dead. help asap

well, just got back. still no luck. the battery is fine, i swapped the battery from my cj in and still no luck. the yj battery also starts and runs my cj easily. Where am I looking for fusible links? What do they look like? is there a way to just bypass something and give the vehicle 12v to make sure that it really is the fusible link(s)? pictures would be a huge help, as right now i'm just driving back and forth from the crash site, which is 5 miles from my house. thanks,
pablo
YJOwnr22 is offline  
post #10 of (permalink) Old 06-11-2004, 04:30 AM Thread Starter
 
Join Date: Oct 2002
Posts: 713
Thanks: 0
Thanked 0 Times in 0 Posts
 
Re: just in a wreck..elect sys totally dead. help asap

btt anybody?
YJOwnr22 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Off-Road Forums & Discussion Groups forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome