The TH350 is making trouble! - Off-Road Forums & Discussion Groups
Jeep-Short Wheelbase All discussion of short wheelbase Jeeps: CJ, TJ, YJ and JK

 
LinkBack Thread Tools Display Modes
post #1 of (permalink) Old 03-05-2004, 03:06 AM Thread Starter
 
Join Date: May 2003
Posts: 58
Thanks: 0
Thanked 0 Times in 0 Posts
 
The TH350 is making trouble!

When I put the TH350 in "P", it seems like the lever on the TH350 gets stuck. When I want to go from "P" to "D", the lever won't move at all. I have to use force to get it "unstuck". Any ideas to what the problem is here?
cj5with454bb is offline  
Sponsored Links
Advertisement
 
post #2 of (permalink) Old 03-05-2004, 06:50 AM
Keyboard Implanted
 
Join Date: Aug 2001
Location: Vermont
Posts: 2,348
Thanks: 0
Thanked 0 Times in 0 Posts
 
Re: The TH350 is making trouble!

It sounds like a linkage problem more than a transmission problem.
What kind of linkage do you have. Do you have a conversion shift kit on it. If so you may have a kink in the cable.
Provide us with just a little more info about the problem
When in drive or "R" Does the trans over rev, or slip?
Olin18 is offline  
post #3 of (permalink) Old 03-05-2004, 08:06 AM
Official Historian
 
WILL's Avatar
 
Join Date: Sep 1999
Location: Hot Springs, AR
Posts: 8,339
Thanks: 1
Thanked 5 Times in 5 Posts
 
Re: The TH350 is making trouble!

Does it do it if you set the parking brake first and then shift into and out of park? It's probably just the pressure on the parking prawl from holding the jeep still.
WILL is offline  
Sponsored Links
Advertisement
 
post #4 of (permalink) Old 03-05-2004, 09:36 AM Thread Starter
 
Join Date: May 2003
Posts: 58
Thanks: 0
Thanked 0 Times in 0 Posts
 
Re: The TH350 is making trouble!

I took the linkage from a Mazda 626. Don't know if that model is available over there, but here in Denmark, Scandinavia, it is very common. The linkage is floor mounted and operated by cable.

If I go in and out of P, there is no trouble
cj5with454bb is offline  
post #5 of (permalink) Old 03-05-2004, 09:38 AM Thread Starter
 
Join Date: May 2003
Posts: 58
Thanks: 0
Thanked 0 Times in 0 Posts
 
Re: The TH350 is making trouble!

BTW the trans doesn't slip or rev. It's newly rebuild and works otherwise perfect
cj5with454bb is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Off-Road Forums & Discussion Groups forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome