2003 wrangler "rubicon" porportioning valve??? - Off-Road Forums & Discussion Groups
Jeep-Short Wheelbase All discussion of short wheelbase Jeeps: CJ, TJ, YJ and JK

 
LinkBack Thread Tools Display Modes
post #1 of (permalink) Old 01-29-2004, 08:13 PM Thread Starter
Old Hand
 
Neurosis's Avatar
 
Join Date: Feb 2003
Location: WA
Posts: 520
Thanks: 0
Thanked 0 Times in 0 Posts
 
2003 wrangler \"rubicon\" porportioning valve???

Well, I hope that there is some difference. My 97 valve looks identicle to this one. I just bought a valve from the parts store for a 2003 rubicon that comes with rear disc in hopes that it will work with my new ford 8.8 rear discs. I hope its different than what I already have but it looks exactly the same. I guess i will compare part numbers before installing it.
Neurosis is offline  
Sponsored Links
Advertisement
 
post #2 of (permalink) Old 01-30-2004, 11:08 AM Thread Starter
Old Hand
 
Neurosis's Avatar
 
Join Date: Feb 2003
Location: WA
Posts: 520
Thanks: 0
Thanked 0 Times in 0 Posts
 
Re: 2003 wrangler \"rubicon\" porportioning valve???

well, for any of you folks that are doing the 8.8 swap or rear disc conversion in your 97 or newer wrangler, the rubicon porportioning valve is a bolt in item. I noticed on the zj there is some kind of splitter needed but this thing is exact. The holes to the rear brakes were noticabley different and so was the part number. I'll post later after getting them blead how they work.
Neurosis is offline  
post #3 of (permalink) Old 01-30-2004, 11:43 PM
 
Join Date: Sep 2001
Posts: 859
Thanks: 0
Thanked 0 Times in 0 Posts
 
Re: 2003 wrangler \"rubicon\" porportioning valve???

noted, appreciate the info/input. Will do upon upgrade! [img]images/graemlins/AR15firing.gif[/img]
mobdawg is offline  
Sponsored Links
Advertisement
 
post #4 of (permalink) Old 02-01-2004, 11:17 PM Thread Starter
Old Hand
 
Neurosis's Avatar
 
Join Date: Feb 2003
Location: WA
Posts: 520
Thanks: 0
Thanked 0 Times in 0 Posts
 
Re: 2003 wrangler \"rubicon\" porportioning valve???

by the way, i forgot to mention that the electrical connector that plugs in to this valve plugs right in. I notice from my readings that the ZJ swap does not. It seems to be working like a charm. Thanks to taz for the bleeding suggestions, my brakes work great now.
Neurosis is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Off-Road Forums & Discussion Groups forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome