Off-Road Forums & Discussion Groups

Off-Road Forums & Discussion Groups (https://forums.off-road.com/forum.php)
-   Jeep-Short Wheelbase (https://forums.off-road.com/jeep-short-wheelbase/)
-   -   help me with my 304!!!!!! (https://forums.off-road.com/jeep-short-wheelbase/172194-help-me-my-304-a.html)

mangu43 07-24-2003 05:52 PM

help me with my 304!!!!!!
 
Hello all, I am trying to get my 77 CJ-7 running and up on the road. It has the 304, and I installed a carb that I rebuilt out of an 83 waggy. It has a few extra vacuum lines coming out of it, and was wondering if anyone knew the least amout of hoses that I would need for good performance. There is no emissions law in Vermont. The bare minimum would be great!
Secondly, I thought that I was ready for a road test, but took it out in my neighborhood, only to have it stall when any load whatsoever was placed on the engine. This seems odd to me, because it fires up well, idles well, and revs to approximately 3000 rpm without hesitation, but only when it is neutral. If a load is placed on it, (like the huge stress of driving on flat pavement) it bucks, backfires, and slows to a near stopped engine speed, however, if I depress the clutch, the engine recovers, and is fine like nothing happened. I have replaced the coil, sparks, wires, rotor, cap, and have upgraded the prestolite bid system to a motorcraft ignition system using the distributor, and icm out of a waggy. The icm tested fine at the parts store. Any suggestions, encouragement? Thanks.

balanced 07-24-2003 10:07 PM

Re: help me with my 304!!!!!!
 
Well
I don't claim to know alot about carbs - but I think I would check the fuel filter if I were you. Let us know how it works out [img]images/graemlins/burnout.gif[/img]

ddieken 07-24-2003 10:38 PM

Re: help me with my 304!!!!!!
 
I agree with Balanced about the fuel filter. The problem you describe sounds like a fuel delivery issue. I would also check the fuel pump pressure and flow rate. If the carb is out of a mid 80s Waggy, you probably have the Motorcraft 2100. The only two lines that come to mind right now are the PCV and the one on the side of the carb for the distributor advance. I would consider that to be the bare minimum.

mangu43 07-25-2003 03:28 AM

Re: help me with my 304!!!!!!
 
thanks, i'll check that tomorrow.

mangu43 09-02-2003 04:20 PM

Re: help me with my 304!!!!!!
 
fixed it! I replaced the fuel pump already, but must have installed it improperly or got a bum one. But anyway, put in a new pump, and it runs like a champ, except for a knock on the first cylinder of the drivers' bank. Hopefully, a little timing will fix that. Thanks guys!


All times are GMT -5. The time now is 05:55 PM.

Powered by vBulletin® Copyright ©2000 - 2021, Jelsoft Enterprises Ltd.

User Alert System provided by Advanced User Tagging (Pro) - vBulletin Mods & Addons Copyright © 2021 DragonByte Technologies Ltd.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2021 DragonByte Technologies Ltd.
Copyright 1994-2009, VerticalScope Inc. // Off Road forums & discussion groups sitemap
side by side | atv | dirtbike | snowmobile | sandsport | competition | land use | Jeep | Toyota | Ford | GM

 
For the best viewing experience please update your browser to Google Chrome