Follow up on AGR PS trouble. - Off-Road Forums & Discussion Groups
Jeep-Short Wheelbase All discussion of short wheelbase Jeeps: CJ, TJ, YJ and JK

 
LinkBack Thread Tools Display Modes
post #1 of (permalink) Old 12-16-2002, 12:29 PM
**DONOTDELETE**
Guest
 
Posts: n/a
Follow up on AGR PS trouble.

I've tried all the solutions for my lack of power assist at idle. AGR says I probably just got a bad pump and to send it back to Summit. We'll see if this works.

One question though. In my '82 factory repair manual it says that the CJ pump puts out less pressure than a GW pump. I thought they were the same. I am using a CJ pump on a GW 360. Should I ask for the GW pump when I get my new pump from Summit?

Thanks

Shawn
Sponsored Links
Advertisement
 
post #2 of (permalink) Old 12-16-2002, 01:03 PM
Enthusiast
 
JEEPININMEXICO's Avatar
 
Join Date: Mar 2001
Location: Tecolutla, Veracruz Mexico
Posts: 226
Thanks: 0
Thanked 0 Times in 0 Posts
 
Re: Follow up on AGR PS trouble.

While I was waiting for my pump to come back from AGR I modified my own pump, increased the pressure, and all worked well. I infact had a bad AGR pump. I think that AGR lets a lot of bad pumps by. They will fix it with no problem. It just takes time. Tell AGR what you have and they will get you on the right pump. They are realy nice to talk to. I do not have their phone number any more. They are in Texas and I got the phone number from the web site.

I love the system and it works well. My next mod is the Hydro-boost setup, using the AGR pump. I am sure it will have enough pressure and volume to work the breaks and the stearing.

Problem is finding one here in Mexico. When I go to the border I am always short on time. Anyone have a hydra=boost they want to sell????

JEEPININMEXICO is offline  
post #3 of (permalink) Old 12-16-2002, 01:16 PM
**DONOTDELETE**
Guest
 
Posts: n/a
Re: Follow up on AGR PS trouble.

I have talked to AGR a couple times for this problem and they were helpful each time. I just called them again to see if there was a difference in the CJ and wagoneer pumps and they are identical as far as they know.

I really hope a new pump works, but I don't have much faith. Everything worked fine in stock form. Then I put the V8 in, and changed to a used AGR box with stock pump. I also changed the lines. I had very little power assist so I switched to the AGR pump with no improvement. Then I switched the box out for a new AGR box. Things improved, but still no power assist at idle. Maybe a new pump is all I need, but my old pump worked fine until I hooked it up to the AGR box with the new lines. Although I did have to change the fittings in the back since it was for an "o" ring hose, and wouldn't fit with the old style hoses and box I was using. Maybe I messed it up when I put then new fitting on the back.

Who knows...

Shawn

Sponsored Links
Advertisement
 
post #4 of (permalink) Old 12-16-2002, 07:25 PM
Keyboard Implanted
 
elusive's Avatar
 
Join Date: Nov 1999
Location: temecula, CA
Posts: 4,893
Thanks: 0
Thanked 1 Time in 1 Post
 
Re: Follow up on AGR PS trouble.

my agr pump crapped out on me after about 2 months of use. i sent it back and they told me i ran it out of fluid.... which i did NOT. bottom line .. i had to pay $100 for them to rebuild it and shipping. I modified my stock pump and I still have the agr pump new in the box... i dont trust it enough to put it in.
I will NEVER do any business with agr again as i was called a liar and they didnt work with me at all.... and not only on the pump, but on the rock ram that bent on me as well.
elusive is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Off-Road Forums & Discussion Groups forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome