Needing help, YJ will not run right - Off-Road Forums & Discussion Groups
Jeep-Short Wheelbase All discussion of short wheelbase Jeeps: CJ, TJ, YJ and JK

Reply
 
LinkBack Thread Tools Display Modes
post #1 of (permalink) Old 11-19-2002, 11:11 PM Thread Starter
 
Join Date: Oct 2001
Posts: 409
Thanks: 0
Thanked 0 Times in 0 Posts
 
Needing help, YJ will not run right

OK here is the deal. A week ago i replaced my thermostat with a new 195. Now ever since we have owned the jeep it never went over 160. (ownership for appx. 5 years)- just thought it was a cool running engine. Then stuff started to heppen. The idle used to be perfect, but gas milage was less than par, 10 mpg. Ok, after the thermostat was replaced and the temperature climbed up to 195-200 and sat there. Yes it would rev up much more smoothy. Although it started to boggel at idle, unconsistant.

Then one nithgt it sat outside and it got really cold. Once the temp was up, it was all i could do to keep the blasted thing from dieing. It is a nutter carter. My theory is that the choke is now turining off and i am runnin gout of fuel at idle. Yes i have tried to adjust the idle and mixture screws. I also replaced the 2 base gaskets.

Can somebody please help me un disclose my vaccum readings also?

-no Load-
idle- 15
2000 rpm- 16
WOT- 0

-load-
2000 rpm (steady throttle)- 15
deceleration- 15 drops to 0
Apply 1/2 thorttle- 5

I also did a volt meter test on the disconnected 02 Sensor-
normally it sits round 6 volts, from a 12v power supply.

I have also installed new plugs, gapped to 35, wires, and cap. All tripple checked on instalation.
Thank you.
87Warrior is offline  
Sponsored Links
Advertisement
 
post #2 of (permalink) Old 11-20-2002, 05:48 PM Thread Starter
 
Join Date: Oct 2001
Posts: 409
Thanks: 0
Thanked 0 Times in 0 Posts
 
Re: Quick Help need, YJ will not run right

More info... Retested the timming, it was at 4 btdc. So i bumped it up to 8 and it smoothed out very nicely. But there was still a "mis" comming from the tail pipe. I rechecked the plugs, (gap), wires, and cap. I am stumped.
-The plugs looked fine, a nice caremal color-
87Warrior is offline  
post #3 of (permalink) Old 11-20-2002, 06:54 PM
BigJ
Guest
 
Posts: n/a
Re: Quick Help need, YJ will not run right

I just went through getting my 88 YJ through emissions testing. I replaced carb, O2, distributor, wires plugs, vac hoses, etc. If you're doing the nutter carb and the computer is out of the loop, I say it is the mixture screws. When mine was purring it would fail emissions testing because it was too rich. Lean it out (timing 8 deg btdc) and it would get a rough idle at the pipe like yours. I replaced the thermostat on mine as well and for some reason that I haven't spent the time to trace yet, after it would run for about 20min or so the choke would lose voltage. I pulled over and whipped out a voltmeter to confirm. I just wired the choke to a 12V source and went around the oil pressure switch. I would shut it down and let it cool and it would run fine and the choke would have power for another 20-30 minutes or so.
Sponsored Links
Advertisement
 
post #4 of (permalink) Old 11-20-2002, 08:43 PM Thread Starter
 
Join Date: Oct 2001
Posts: 409
Thanks: 0
Thanked 0 Times in 0 Posts
 
Re: Quick Help need, YJ will not run right

I have adjusted the mixture screws some. Now they are about 5 1/4 turns out. does that seem right? Could faulty plug wires also be at fault?? The nutter was done about a year ago... Could the Meetering pins been moved? I am stumped.

I bet your choke looses power becasue it is shuting down becasue the engine has warmed up past 160...
87Warrior is offline  
post #5 of (permalink) Old 11-21-2002, 02:40 PM
BigJ
Guest
 
Posts: n/a
Re: Quick Help need, YJ will not run right

Check the wires and use a dielectric grease to seal them. Cracked distributor or rotor? Sometimes you can't see the crack. I still think it is the choke. Pull the air inlet to the carb off when it runs rough after it is hot. If the plate is closed (should be straight up and down) you probably have a bad sending unit. Have you checked the fuel filter. Mine would run rough and then die because the choke would shut off completely and the plate would close and let no air in. Vacuum leaks?
post #6 of (permalink) Old 11-21-2002, 03:39 PM
 
Join Date: Oct 2002
Posts: 713
Thanks: 0
Thanked 0 Times in 0 Posts
 
Re: Quick Help need, YJ will not run right

5 1/4 turns out is a bit too far. Rule of thumb: 2.5 turns out to get started, but you shouldn't have to go another 3 out to get a good smooth idle. Have you checked for leakage at the intake manifold gaskets? Warpage is also a common problem with the 258, I'm told....

YJOwnr22 is offline  
post #7 of (permalink) Old 11-22-2002, 01:42 PM Thread Starter
 
Join Date: Oct 2001
Posts: 409
Thanks: 0
Thanked 0 Times in 0 Posts
 
Re: Quick Help need, YJ will not run right

I will check the fuel filter and what not. I also am planning on doing a 4.0 head swap so i will check the intake when it is off... I will set the idle mixture screws 3 turns in. There are 2 really loose plug wires, i might need to get something above bottom of the line next time... I have checked the choke, the plate is straight up and the fast idle cam is off, shoulud that happen??? I am also going to get a new rotor and wires. The plugs look good though, nice caremal color. Any other ideas of wisdom??
87Warrior is offline  
post #8 of (permalink) Old 11-23-2002, 12:25 AM Thread Starter
 
Join Date: Oct 2001
Posts: 409
Thanks: 0
Thanked 0 Times in 0 Posts
 
Re: Quick Help need, YJ will not run right

I replaced the wires, and put some dielectric grease on them. It still does the same thing. But here is something new. IT will run perfect if you hold the choke plate all the way down. This would mean it has a natural lean condition. Right? Whay would this be, gummed up carb? Should anothr carb work for me and cure my jeep? Thanks
87Warrior is offline  
post #9 of (permalink) Old 11-26-2002, 09:19 AM
MaineJeep
Guest
 
Posts: n/a
Re: Quick Help need, YJ will not run right

You have a vacuum leak somewhere.
post #10 of (permalink) Old 11-26-2002, 11:50 AM
 
Join Date: Sep 1999
Posts: 2,006
Thanks: 0
Thanked 0 Times in 0 Posts
 
Re: Quick Help need, YJ will not run right

while motor is running and air cleaner in place spray some carb cleaner all around the carb base and the intake where it mates to the head if you get an increase in rpms doing this. Pin point the area and that is your vacuum leak. The 258 has a bad habit of leaking on the intake to head mating area as well as the exhaust to intake mating area.
GP'n is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Off-Road Forums & Discussion Groups forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome