Winch no worky - Off-Road Forums & Discussion Groups
Jeep-Short Wheelbase All discussion of short wheelbase Jeeps: CJ, TJ, YJ and JK

 
LinkBack Thread Tools Display Modes
post #1 of (permalink) Old 09-17-2002, 06:05 PM
**DONOTDELETE**
Guest
 
Posts: n/a
Winch no worky

Superwinch S9000. It worked the last time I used it, and no, it didn't overheat or anything. Now it doesn't work. When I hit the button, it doesn't move in either direction, and doesn't make any noises (no clicks, whirrring or anything).

The cable connections to the battery are good. Any ideas?
Sponsored Links
Advertisement
 
post #2 of (permalink) Old 09-17-2002, 07:12 PM
balanced
Guest
 
Posts: n/a
Re: Winch no worky

If you have cheched the connections to the battery then what type of control cable do you have? My Warn has a cable that plugs in to run the winch in & out. If yours has one of those check the connections on both ends for any signs of corrosion.
Outside of that I believe that under the cover somewhere there are some solanoids that work the motor. That would be the other option.
Good luck
post #3 of (permalink) Old 09-17-2002, 07:16 PM
Carpal \'Tunnel
 
knifeboy2's Avatar
 
Join Date: Jul 2002
Location: Macomb, IL
Posts: 2,571
Thanks: 0
Thanked 0 Times in 0 Posts
 
Re: Winch no worky

You have checked that the connections are good to the battery. Have you checked that the power is going all the way to the winch? I had a similar problem once and I kicked myself when I realized it was just a blown fuse. Follow the cables from the battery to the winch to make sure that no peice in between has failed. If the power is making it to the winch then I don't know what the problem is.
knifeboy2 is offline  
Sponsored Links
Advertisement
 
post #4 of (permalink) Old 09-17-2002, 07:22 PM
I Might Just Know What I'm Talking About
 
Raduckal's Avatar
 
Join Date: Sep 1999
Location: Owensboro, KY
Posts: 1,905
Thanks: 3
Thanked 4 Times in 4 Posts
 
Re: Winch no worky

If you are useing a remote cable, check it's connections too. You can jump the terminals at the switch connection point to rule out any remote/remote cable problems.
Raduckal is offline  
post #5 of (permalink) Old 09-17-2002, 07:29 PM
**DONOTDELETE**
Guest
 
Posts: n/a
Re: Winch no worky

I got it. It was a bad connection at the switch. Thanks y'all.
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Off-Road Forums & Discussion Groups forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome