New Engine... Bad Noise!! - Off-Road Forums & Discussion Groups
Jeep-Short Wheelbase All discussion of short wheelbase Jeeps: CJ, TJ, YJ and JK

 
LinkBack Thread Tools Display Modes
post #1 of (permalink) Old 07-30-2002, 08:30 PM
**DONOTDELETE**
Guest
 
Posts: n/a
New Engine... Bad Noise!!

Hello everyone,
I just put a rebuilt engine in from ATK... This is my first time putting an engine in. Everything went great except there is a bad clank sound coming from where the engine and bellhousing is coming from. Its hard to tell what its coming from. I have an automatic and it only does when in gear. It does it a little bit when in park and at higher RPM's. I'm not sure if i did something wrong. I'm thinking its the torque converter. I'm sure i installed it correctly any ideas????
Thanks
Sponsored Links
Advertisement
 
post #2 of (permalink) Old 07-31-2002, 08:03 AM
Way Outta Control
 
Join Date: Sep 1999
Location: The Palouse
Posts: 13,432
Thanks: 1
Thanked 3 Times in 3 Posts
 
Re: New Engine... Bad Noise!!

Have you:
1. Rremoved the flexplate to converter bolts.
2. Slid back the converter.
3. Started the engine.
4. Listened for the noise?

This isonlates the noise between the engine and the rest of the drive train. That's where I'd start.
LEVE is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Off-Road Forums & Discussion Groups forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome