EGR System - Off-Road Forums & Discussion Groups
Jeep-Full Sized All discussion of full sized Jeeps: Wagoneer, Full Size Truck

 
LinkBack Thread Tools Display Modes
post #1 of (permalink) Old 09-29-2001, 01:07 AM
**DONOTDELETE**
Guest
 
Posts: n/a
EGR System

After months of troubleshooting my ignition system including spark, timing, and all vaccum related issues. I have finally REMOVED the egr valve from the vaccum system. I have been told that this system is supposed to make the engine run cooler, and help with economy. After removing it altogether the truck will finally idle correctly and it has removed all pinging under acceleration. It has also had absolutely no effect on the engines running temperature. Can anybody tell me why this is so?
Thanks,
Chris


If it can't be done from the seat of a Jeep, it don't need to get done!
Sponsored Links
Advertisement
 
post #2 of (permalink) Old 09-29-2001, 02:42 AM
Keyboard Implanted
 
Join Date: Sep 1999
Location: Near Chicago, IL
Posts: 2,537
Thanks: 0
Thanked 1 Time in 1 Post
 
Re: EGR System

Your EGR valve may have been stuck. But more than likely you had a vacuum leak through a hole in the diaphragm inside the valve.

"Every form of refuge has it's price."
Andytron is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Off-Road Forums & Discussion Groups forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome