Isuzu Trooper High Beam Malfunction - Off-Road Forums & Discussion Groups
Isuzu Honda Discussion of all Isuzu, off-road vehicles and clones (Honda).

 
LinkBack Thread Tools Display Modes
post #1 of (permalink) Old 03-17-2004, 02:09 PM
joepoisson
Guest
 
Posts: n/a
Isuzu Trooper High Beam Malfunction

I have a 91 Trooper that has a short somewhere in the lighting system. The taillights/dash lights are on the same fuse and when I turn on the headlights, the fuse burns out. Additionally, my highbeams don't work. When I push the switch for the highbeams, the lights go out completely...when I pull it back they come back on. I thought it was a faulty highbeam relay and switched it with another... the problem is the same. Could it be the headlight switch itself, or is there another realy under the hood? All other lights work fine so it seems to me that the problem is centered around the highbeams and running lights. Any info would be great! Thanks, Joe
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Off-Road Forums & Discussion Groups forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome