Body mount question - Off-Road Forums & Discussion Groups
IH Scout & Trucks Discussion of International Harvester, 4-Wheel Drive Truck and Scout Vehicles

 
LinkBack Thread Tools Display Modes
post #1 of (permalink) Old 01-26-2000, 06:55 PM
**DONOTDELETE**
Guest
 
Posts: n/a
Body mount question

Hi there. My 78 Scout II's front and rear body mounts are all eaten away, but still connected. Is there any cure for them, or is it just a matter of time before they erode completely. I've been told that the only remedy is to take the cab off and rebuilt the frame. Is this the case? Or is there some way I can shore them up, replace them or repair them. Pretty new to IH, but handy with tools. Thanks, Please email responses to [email protected]

Sponsored Links
Advertisement
 
post #2 of (permalink) Old 01-27-2000, 10:40 AM
**DONOTDELETE**
Guest
 
Posts: n/a
Re: Body mount question

If these are the body mounts just ahead of and behind the cab then I'm in the same boat.
This seems to be a common problem. I will order new mounts, cut out the old ones, and
plug weld the new ones in from above, as soon as I have some floor boards to weld to that is.
Also check out this page from Binder Bulletin.

http://www.binderbulletin.org/faq/2.htm#3

Jorg

Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Off-Road Forums & Discussion Groups forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome