Off-Road Forums & Discussion Groups

Off-Road Forums & Discussion Groups (https://forums.off-road.com/forum.php)
-   GM Standard SFA Trucks & SUV's (https://forums.off-road.com/gm-standard-sfa-trucks-suvs/)
-   -   NP 208 issues (https://forums.off-road.com/gm-standard-sfa-trucks-suvs/227992-np-208-issues.html)

captainofiron 01-26-2008 08:22 PM

NP 208 issues
 
The Transfer Case in my K10 has bee acting weird

I was pulling a buddy with a Cherokee out of the mud, when I heard a pop, then it sounded like loose bolts rolling around in a tin coffee can, and then the Truck stopped moving and acted like I had put it in Neutral. I put it back into 2wd and it ran fine, but I put it back into 4wd and nothing, neutral again. Well I turned her off and a friend 96 K1500 tried to pull him out but it didnt work.

So about a half hour later I tried my K10 again and like a champ it went into 4wd and dragged the XJ out like a walk in the park.

So anybody have this problems with a NP208 transfer case?

I am thinking its the engagement gear or something in the case


All times are GMT -5. The time now is 09:45 AM.

Powered by vBulletin® Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.

User Alert System provided by Advanced User Tagging (Pro) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.
Copyright 1994-2009, VerticalScope Inc. // Off Road forums & discussion groups sitemap
side by side | atv | dirtbike | snowmobile | sandsport | competition | land use | Jeep | Toyota | Ford | GM

 
For the best viewing experience please update your browser to Google Chrome