'84 Sub:Poor air flow through vents and defrosters - Off-Road Forums & Discussion Groups
GM Standard SFA Trucks & SUV's All discussion of full sized Solid Front Axle Trucks, SUV's to include Suburban

 
LinkBack Thread Tools Display Modes
post #1 of (permalink) Old 10-20-2005, 01:45 PM Thread Starter
Veteran
 
DaveGoodrich's Avatar
 
Join Date: Sep 1999
Location: Redlands, California
Posts: 1,220
Thanks: 0
Thanked 0 Times in 0 Posts
 
\'84 Sub:Poor air flow through vents and defrosters

I don't get much air going to either the dash vents or the defrosters on my '84 suburban. On either setting, most of the air still goes out the floor heater ducts, although the controls do have some effect. I am guessing that there is a flap inside the heater box that is supposed to direct the air, and either it is not moving completely, or it has a seal that is worn out.

Can anybody give me any guidance on how to diagnose and repair this?
DaveGoodrich is offline  
Sponsored Links
Advertisement
 
post #2 of (permalink) Old 10-21-2005, 09:31 AM
 
Join Date: Aug 2005
Posts: 118
Thanks: 0
Thanked 0 Times in 0 Posts
 
Re: \'84 Sub:Poor air flow through vents and defrosters

when you move the vent selector, does it feel loose in anyway? your body style used mechanical hinge thingys to close and open the airflow and youd be able to feel if they were loose. If thats the case then youve gotta go under the dash and repair them. the repair should be simple but getting under the dash to the right place will be a pain in the butt. i dont think there is a seal that is worn out, b/c those units work like a butterfly on a throttle body. it could also just be a bad blower. let me know how it goes.
TNCowboyPRCA is offline  
post #3 of (permalink) Old 10-21-2005, 09:52 AM Thread Starter
Veteran
 
DaveGoodrich's Avatar
 
Join Date: Sep 1999
Location: Redlands, California
Posts: 1,220
Thanks: 0
Thanked 0 Times in 0 Posts
 
Re: \'84 Sub:Poor air flow through vents and defrosters

Thanks for the info. The control moves easily, but doesn't seem totally loose (like a broken cable). Like I said, the control does have some effect (some air comes out the defroster or dash vents, depending on where the lever is set, but most of the air comes out through the floor ducts, no matter where the lever is set.

Thanks again,
Dave
DaveGoodrich is offline  
Sponsored Links
Advertisement
 
post #4 of (permalink) Old 10-21-2005, 01:42 PM
 
Join Date: Sep 2005
Posts: 19
Thanks: 0
Thanked 0 Times in 0 Posts
 
Re: \'84 Sub:Poor air flow through vents and defrosters

I have a 86 Silverado pickup and the heater is controled by vacuum operated doors in the system. My guess is one or more of the rubber hoses have dried out and split under the dash or under the hood. There should also be a black (kind of round shaped) vacuum storage canister under the hood on the drivers side near the hood hinge. That sometimes cracks and if there's no vacuum then the heater doors won't work.

Good luck...
Wishin2BTrackin is offline  
post #5 of (permalink) Old 10-22-2005, 01:45 PM Thread Starter
Veteran
 
DaveGoodrich's Avatar
 
Join Date: Sep 1999
Location: Redlands, California
Posts: 1,220
Thanks: 0
Thanked 0 Times in 0 Posts
 
Re: \'84 Sub:Poor air flow through vents and defrosters

Thanks, the vacuum thing sounds like a likely source of the problem. I will take a look today. Hopefully, I won't have to take the dash apart to find the hoses.

Thanks again,
Dave
DaveGoodrich is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Off-Road Forums & Discussion Groups forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome