More TH700 drama! - Off-Road Forums & Discussion Groups
GM Standard SFA Trucks & SUV's All discussion of full sized Solid Front Axle Trucks, SUV's to include Suburban

 
LinkBack Thread Tools Display Modes
post #1 of (permalink) Old 12-12-2004, 09:36 AM Thread Starter
Can't Get Enough
 
Join Date: Dec 2002
Location: Texas
Posts: 1,113
Thanks: 0
Thanked 2 Times in 2 Posts
 
More TH700 drama!

I htought I got all of my tranny problems sorted out and now this... It's making a whining/whistling sound when I drive. It's most noticeable in higher gears and speeds. I think its the pump, but not too sure. Could it be something else, or is it about time for a rebuild?

Thanks.
c_rock is offline  
Sponsored Links
Advertisement
 
post #2 of (permalink) Old 12-16-2004, 05:58 PM Thread Starter
Can't Get Enough
 
Join Date: Dec 2002
Location: Texas
Posts: 1,113
Thanks: 0
Thanked 2 Times in 2 Posts
 
Re: More TH700 drama!

What, no help? Oh well, OD is gone now so I think a major rebuild is on the way. I'll take it in after the holidays.
c_rock is offline  
post #3 of (permalink) Old 12-17-2004, 02:25 AM
I Might Just Know What I'm Talking About
 
TxFireman's Avatar
 
Join Date: Aug 2001
Location: San Antonio, TX
Posts: 1,582
Thanks: 0
Thanked 2 Times in 2 Posts
 
Re: More TH700 drama!

Sorry man, didn't see your post.. since the new changes it does not show the new posts in this forum for me... it just looks like there are no new ones which makes it a little harder to see them.

Anyway, I'm not much of a tranny expert, but I'd say it does not sound good... it's not throwing any codes? When mine started going out it did,and a tranny shop scanned it for me for free. They said it would last a long time.... but it was going to need a rebuild. So, once I got back home (I was out of town) I just went ahead and had it rebuilt. Good luck with it..
TxFireman is offline  
Sponsored Links
Advertisement
 
post #4 of (permalink) Old 12-17-2004, 10:06 PM
 
Join Date: Jan 2003
Posts: 292
Thanks: 0
Thanked 0 Times in 0 Posts
 
Re: More TH700 drama!

it might be the planitary gears in it mine does it till i warms up
snowmancat is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Off-Road Forums & Discussion Groups forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome