My '89 K5 Is Slow - Off-Road Forums & Discussion Groups
GM Standard SFA Trucks & SUV's All discussion of full sized Solid Front Axle Trucks, SUV's to include Suburban

Reply
 
LinkBack Thread Tools Display Modes
post #1 of (permalink) Old 10-21-2002, 08:30 PM
**DONOTDELETE**
Guest
 
Posts: n/a
My \'89 K5 Is Slow

Hey i was woundering if anyone else has this problem with their '89 K5 Blazer. My engine, tranny, and gears are stock and i am running 33in BFG's with a 2in spring lift. My acceleration sucks and my tranny wont shift at anything over half throttle. Im thinking of putting 4.10's in her, but would be a waste of time. Help would be appreciated.
Sponsored Links
Advertisement
 
post #2 of (permalink) Old 10-21-2002, 08:58 PM
 
Join Date: Oct 2002
Posts: 146
Thanks: 0
Thanked 0 Times in 0 Posts
 
Re: My \'89 K5 Is Slow

what motor tranny and gears do you have now?
chevyman_400 is offline  
post #3 of (permalink) Old 10-21-2002, 09:04 PM
**DONOTDELETE**
Guest
 
Posts: n/a
Re: My \'89 K5 Is Slow

700 R4-Trans
5.7l 350 EFI-Motor
Gears are stock maybe 3.73, not sure
i have [bleep] for acceleration and i wont shift unless i let off. It also shifts late. Over Drive wont kick in till like 65mph and it down shifts into 3rd at 60mph
Sponsored Links
Advertisement
 
post #4 of (permalink) Old 10-21-2002, 09:08 PM
Carpal \'Tunnel
 
wrath's Avatar
 
Join Date: Nov 2001
Location: Waukesha, WI
Posts: 3,323
Thanks: 0
Thanked 1 Time in 1 Post
 
Re: My \'89 K5 Is Slow

You probably have 3.08s.

Did you have the same problem with little tires?

You can use the RPO codes to find out what ratio:
Code Ratio
GU2 2.73
GU4 3.08
GU5 3.23
GU6 3.42
GT4 3.73
GT5/GT8 4.10

wrath is offline  
post #5 of (permalink) Old 10-21-2002, 09:27 PM
87sm465np208
Guest
 
Posts: n/a
Re: My \'89 K5 Is Slow

yeap sounds like my friends blazer, my truck has 3.73's, it accelerates very well, my friend has 3.73's in his 89 suberban, it goes super fast, sounds like you need some 3.73's or smaller tires.
post #6 of (permalink) Old 10-22-2002, 07:13 AM
Kendog454
Guest
 
Posts: n/a
Re: My \'89 K5 Is Slow

or a blown 540 merlin!! [img]images/graemlins/grin.gif[/img]
post #7 of (permalink) Old 10-22-2002, 11:53 AM
Can't Get Enough
 
A1980GMC's Avatar
 
Join Date: Oct 2000
Location: McKinney, Texas
Posts: 1,293
Thanks: 0
Thanked 0 Times in 0 Posts
 
Re: My \'89 K5 Is Slow

When you give it the gas does it start to shudder? My 92 Blazer did that and it would not start a few times. I went through a fuel pump, plugs, wires until I found out it was the dist. replaced that and it ran great.

Laters, Ryan
A1980GMC is offline  
post #8 of (permalink) Old 10-23-2002, 12:49 AM
**DONOTDELETE**
Guest
 
Posts: n/a
Re: My \'89 K5 Is Slow

Just like my truck does just add alot of vibration and rattleing. Ohh yeah my seat just ripped outta me floor. [img]images/graemlins/frown.gif[/img]
post #9 of (permalink) Old 12-11-2002, 12:21 PM
**DONOTDELETE**
Guest
 
Posts: n/a
RPO codes

My 75 had all the options spelled out on the sticker in glove box, but my 'new' 87 has a bunch of these RPO codes.

I have looked high and low for a listing of these RPO codes. Can you tell me where I can find them.

Thanks [img]images/graemlins/confused.gif[/img]
post #10 of (permalink) Old 12-11-2002, 12:39 PM
**DONOTDELETE**
Guest
 
Posts: n/a
Re: RPO codes

yeah, my buddys '85 (? I'm pretty sure) had the gear ratio listed in the glove box with all the option plain as day 3.73
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Off-Road Forums & Discussion Groups forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome