D60 trak-loc question - Off-Road Forums & Discussion Groups
GM Standard IFS Trucks & SUV's All discussion of full sized IFS Trucks, SUV's to include Suburban

 
LinkBack Thread Tools Display Modes
post #1 of (permalink) Old 06-21-2001, 07:26 AM
**DONOTDELETE**
Guest
 
Posts: n/a
D60 trak-loc question

I just purchased a dana 60 ftont axle with a trak-loc differential. I was wondering how well it will hold and keep both front wheels pulling. Are many people out there running these. Also does it require any special lube or additive? Thanks in advance, StevenJ

Sponsored Links
Advertisement
 
post #2 of (permalink) Old 06-25-2001, 12:48 PM
**DONOTDELETE**
Guest
 
Posts: n/a
Re: D60 trak-loc question

I'm running an extra clutch in mine under my jeep and it works like a detroit!! Actually it doesnt slip at all that I've noticed and I'm running 38 tsls on it...It was a total bitch to put that extra clutch in there but well worth the effort..A detroit is the only true way to go if ya have the cash though..

It's as close to a 1ton as it can get and still be a jeep!!! Gotta love it!!
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Off-Road Forums & Discussion Groups forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome