Newbie Help - Off-Road Forums & Discussion Groups
GM Standard IFS Trucks & SUV's All discussion of full sized IFS Trucks, SUV's to include Suburban

 
LinkBack Thread Tools Display Modes
post #1 of (permalink) Old 03-30-2004, 12:06 PM
GRNJETTA6
Guest
 
Posts: n/a
Newbie Help

I just bought a 1995 Gmc k1500 z71 with 146k. Yesterday the speedo started to act funny bouncing all over than stopping to work all together. The tach and other gauges work but the odometer, tripometer and speedo don't. I replaced the speed sensor and no difference. [img]images/graemlins/AR15firing.gif[/img] electronics
Sponsored Links
Advertisement
 
post #2 of (permalink) Old 04-01-2004, 04:46 PM
jtverrastro
Guest
 
Posts: n/a
Re: Newbie Help

i have an 89 with the same problem. the only thing that works for me is to smash my fist on the dash.
post #3 of (permalink) Old 04-01-2004, 11:40 PM
 
Join Date: Jan 2001
Posts: 4,752
Thanks: 0
Thanked 0 Times in 0 Posts
 
Re: Newbie Help

there is another thread right now about this. its a common issue with the early 90's chevies
u4ia4 is offline  
Sponsored Links
Advertisement
 
post #4 of (permalink) Old 04-02-2004, 12:03 AM
Apprentice
 
Join Date: Sep 2003
Posts: 79
Thanks: 0
Thanked 0 Times in 0 Posts
 
Re: Newbie Help

make sure you battery posts are tight,
classjoe is offline  
post #5 of (permalink) Old 04-02-2004, 03:14 PM
GRNJETTA6
Guest
 
Posts: n/a
Re: Newbie Help

what is the other thread?
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Off-Road Forums & Discussion Groups forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome