94 chevy 1500 fuel or electrical problem - Off-Road Forums & Discussion Groups
GM Standard IFS Trucks & SUV's All discussion of full sized IFS Trucks, SUV's to include Suburban

Reply
 
LinkBack Thread Tools Display Modes
post #1 of (permalink) Old 08-28-2003, 08:05 PM
**DONOTDELETE**
Guest
 
Posts: n/a
94 chevy 1500 fuel or electrical problem

my 94 chevy wont start sometimes. when it is runnung if I try to hit the gas any harder than soft, it will die out on me. Any ideas??
Sponsored Links
Advertisement
 
post #2 of (permalink) Old 08-28-2003, 08:16 PM
 
Join Date: Aug 2000
Posts: 7,863
Thanks: 0
Thanked 0 Times in 0 Posts
 
Re: 94 chevy 1500 fuel or electrical problem

Fuel pump or filter...

Best Auto Insurance | Auto Protection Today | FREE Trade-In Quote
willyswanter is offline  
post #3 of (permalink) Old 09-02-2003, 01:42 AM
Drew K1500
Guest
 
Posts: n/a
Re: 94 chevy 1500 fuel or electrical problem

Sounds like the filter to me. Try that first as its the cheapest.
Sponsored Links
Advertisement
 
post #4 of (permalink) Old 09-03-2003, 01:18 PM
**DONOTDELETE**
Guest
 
Posts: n/a
Re: 94 chevy 1500 fuel or electrical problem

I changed the fuel filter. And it is still giving me problems. If a fuel pump is bad or going bad will it work sometimes and work crappy others and sometimes not at all?
post #5 of (permalink) Old 09-03-2003, 04:03 PM
 
Join Date: Jan 2001
Posts: 4,752
Thanks: 0
Thanked 0 Times in 0 Posts
 
Re: 94 chevy 1500 fuel or electrical problem

yup, the pumpcan cause similar problems. on mine it would start hard sometimes....then it would be fine for a bit. then all of the sudden it just wouldnt start. so i'd tow it home and on the way I'd try and it would start. it was very hit or miss for a week or so. new delco pump and problem is solved
u4ia4 is offline  
post #6 of (permalink) Old 09-04-2003, 03:57 PM
**DONOTDELETE**
Guest
 
Posts: n/a
Re: 94 chevy 1500 fuel or electrical problem

is it possible a dirty filter overworked the pump?
post #7 of (permalink) Old 09-06-2003, 07:10 PM
**DONOTDELETE**
Guest
 
Posts: n/a
Re: 94 chevy 1500 fuel or electrical problem

I tried spraying starting fluid in it and it wouldnt start. If the fuel pump was bad , would it still start if starting fluid was used? I also noticed that the injectors were squirting fuel , would this happen if the pump was bad?
post #8 of (permalink) Old 09-06-2003, 10:44 PM
**DONOTDELETE**
Guest
 
Posts: n/a
Re: 94 chevy 1500 fuel or electrical problem

I replaced my fuel pump , filter and strainer. No progress. Truck still wont start. Ive got spark , fuel, air, exaust, dont know what else it could be.
post #9 of (permalink) Old 09-07-2003, 04:44 AM
bassfishn
Guest
 
Posts: n/a
Re: 94 chevy 1500 fuel or electrical problem

i have had that same experience with my '94 k3500, i had everything that would allow it to start, but would'nt. turns out that my temp sending unit was shorting out at the plug.
i would start moving around some things while someone cranks her, seems like everything runs through the 'puter.

just a thought
post #10 of (permalink) Old 09-08-2003, 09:50 PM
RobRoy
Guest
 
Posts: n/a
Re: 94 chevy 1500 fuel or electrical problem

Just an update. I spent a good portion of the weekend working on goat's truck, with no luck. Today we towed it to the stealership in hopes that they can run a diag. on it and come up with something. I will keep the forum posted on the outcome, in hopes of helping others.
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Off-Road Forums & Discussion Groups forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome