Update on dead ventilation control - Off-Road Forums & Discussion Groups
GM Small Trucks & SUV's All discussion of S-Class Trucks and SUV's

 
LinkBack Thread Tools Display Modes
post #1 of (permalink) Old 05-22-2001, 09:20 AM
**DONOTDELETE**
Guest
 
Posts: n/a
Update on dead ventilation control

I thought I would share my experience in troubleshooting the ventilation control on my 96 Blazer.

Background:
Turning the ventilation control knob was no longer changing the direction of air flow. It was stuck in de-fog mode.

Solution:
I received a tip from a member of this group that it might be a vaccum problem. He suggested that I check the vac lines connected behind the knob....but before you rip out the dash (like I did), check the vaccum filter. It's a small T-connection in the vac-line (back-right corner near the black ball attached to the hood). The T-connection has a filter element...probably for water or oil. It is clogged. I have a strong vac before (engine side) but hardly any on the other side....which means that there is not enough pressure to activate the dampers. I bypassed the connection and all worked great. I will pick-up a new connection on the way home.

Hopes this helps another lost soul,

Snafoo

Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Off-Road Forums & Discussion Groups forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome