vacuum actuator switch - Off-Road Forums & Discussion Groups
GM Small Trucks & SUV's All discussion of S-Class Trucks and SUV's

 
LinkBack Thread Tools Display Modes
post #1 of (permalink) Old 05-12-2001, 01:17 PM
**DONOTDELETE**
Guest
 
Posts: n/a
vacuum actuator switch

hello all,

I have an 86 s10 blazer sport, 2.8 tbi. I suspect that my vacuum actuator switch has gone as my 4x4 symptoms indicate. Has anyone replaced this switch before, and if so ,any suggestions? the s10 4x4 site has some info, but not step by step instructions. Also, my distributor leaks oil, I know there are some rings to be replaced in there, but I know it is in a hard place to get at. Has anyone had the same problem(s), or any advice on how to go about this? any help would be appreciated. Thanks, Jake

Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Off-Road Forums & Discussion Groups forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome