Problems with vent knob - Off-Road Forums & Discussion Groups
GM Small Trucks & SUV's All discussion of S-Class Trucks and SUV's

 
LinkBack Thread Tools Display Modes
post #1 of (permalink) Old 04-23-2001, 08:20 AM
**DONOTDELETE**
Guest
 
Posts: n/a
Problems with vent knob

Hey Guys,
My vent knob seems to be stuck in one mode, defog. When I turn it to Vent, nothing changes...it's OFF or Defog. Is this an electrical problem or mechanical (broken cable)? Any pointers would be appreciated.
Thanks,
Snafoo

Sponsored Links
Advertisement
 
post #2 of (permalink) Old 04-24-2001, 11:15 PM
**DONOTDELETE**
Guest
 
Posts: n/a
Re: Problems with vent knob

Sounds like a vacuum problem. The only cable on the HVAC system controls the cold-hot temp. Pull the control off and you'll see a vacuum harness that plugs into the back of the controls. In the controls there is a sliding disc that directs vacuum from 1 of the hoses to open the different doors inside the dash for defrost, vent, A/C, off, ect. Make sure all the hoses are hooked to the controls and that one of them supplies engine vacuum to it. Good luck with it.
A.Smith

1989 GMC S-15 4x4 4.3L/700R-4, 3.08s, 31" Sport Kings For Sale
1985 S-10 4x4 Soon to have 3504BM/TH350/D44/14FF, 35" Boggers
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Off-Road Forums & Discussion Groups forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome