Hissing heater controls - Off-Road Forums & Discussion Groups
GM Small Trucks & SUV's All discussion of S-Class Trucks and SUV's

 
LinkBack Thread Tools Display Modes
post #1 of (permalink) Old 04-18-2001, 07:53 PM
**DONOTDELETE**
Guest
 
Posts: n/a
Hissing heater controls

I just tore into my dash to replace some burnt out insrument panel bulbs and when I put everything back together and started the truck it started hissing. I can't change where the heat comes from either. It always comes from the window defroster and heater vents at the bottom. The hissing is coming from the vacume lines behind the controls but nothing is cracked (I think) and I can't feel any leaks. Any advice?

Lack of engine proformance equals a limp shaft.
http://members.home.net/jm8881/blazer.html
Sponsored Links
Advertisement
 
post #2 of (permalink) Old 04-18-2001, 08:17 PM
**DONOTDELETE**
Guest
 
Posts: n/a
Re: Hissing heater controls

You probably wouldnt be able to feel any leaks because it is vacum instead of pressure. If it wasnt doing this before you worked on the dash lights I would think that something got pulled loose or a line got a hole in it. You might want to check and make sure where the lines plug to the back of the heater switch is plugged in good. Good luck.

post #3 of (permalink) Old 04-19-2001, 01:00 PM
**DONOTDELETE**
Guest
 
Posts: n/a
Re: Hissing heater controls

i have the same thing... i tore the entire dash apart and diddn't find anything, then i looked down, right next to the driver side ductwork(center of the truck bottom of dash) theres a relay? thingy, i'd look there first

Tim

88 blazer
Like A Rock
Sponsored Links
Advertisement
 
post #4 of (permalink) Old 04-19-2001, 02:54 PM
**DONOTDELETE**
Guest
 
Posts: n/a
Re: Hissing heater controls

It must be an eppodemic with these thing..mines a victim of that too, but if I put the controler between defrost and vent it dont do it and if i have it on defrost ( i get that) and the floor.. It always blows on the floor.

http://members.theglobe.com/moneystight/24_21A.JPG http://members.theglobe.com/moneystight/22_19A.JPG
post #5 of (permalink) Old 04-20-2001, 05:25 PM
**DONOTDELETE**
Guest
 
Posts: n/a
Re: Hissing heater controls

I fixed my controlls. All I did is remove the heater control and all the wireharnesses. I left the vacume tubes on and put the heater controls to off and wiggled all the lines until it stopped hissing. Then I put it to max AC and wiggled it untill it stoped, and so on. My controlls work right now.

Lack of engine proformance equals a limp shaft.
http://members.home.net/jm8881/blazer.html
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Off-Road Forums & Discussion Groups forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome