91 S10 that sputters & Jerks?? - Off-Road Forums & Discussion Groups
GM Small Trucks & SUV's All discussion of S-Class Trucks and SUV's

 
LinkBack Thread Tools Display Modes
post #1 of (permalink) Old 03-02-2001, 05:31 PM
**DONOTDELETE**
Guest
 
Posts: n/a
91 S10 that sputters & Jerks??

Hi all!!!
Here are my symptoms:
If I start it in the morning and allow no warm up time it does fine. If I let it warm up for more than one minute this is what happens. It kicks a code 45 = Rich fuel mixture. It starts at about 15 mph while in first gear. It's like you cut the ignition on and off very fast and it continues in every gear. When it first started it didn't do this at highway speed (60 mph). Now when it throws these fits, it does it constantly at all different speeds. Tomorrow it may throw a fit, the next day it won't. I have noticed that the injector gets a full fuel spray (spurt) not a mist like it's at an idle. Here is a list of parts that have been replaced.
Spark plugs (Autolite)
Spark Plug wires (CarQuest)
Distributor cap (CarQuest)
Rotor button (CarQuest)
PCV Valve (CarQuest)
Ignition module (CarQuest)
Oxygen sensor (CarQuest)
TPS sensor (CarQuest) replaced twice
MAP sensor (CarQuest) replaced twice
EGR valve (CarQuest)
all vacuum hoses replaced
TBI rebuilt (CarQuest)
New injectors (CarQuest)
New fuel pressure regulator (CarQuest)
TBI base gasket (Victor)
New exhaust system including catalytic converter
ECM (Computer)
Temp sensor
Fuel filter
Air filter
I don't have a vacuum leak

Any help is sincerely and greatly appreciated.
Frank



Frank (sometimes Tammy)
Sponsored Links
Advertisement
 
post #2 of (permalink) Old 03-05-2001, 12:30 PM
 
Join Date: Mar 2000
Posts: 534
Thanks: 0
Thanked 0 Times in 0 Posts
 
Re: 91 S10 that sputters & Jerks??

after you get the rich code, you should pull your plugs and see which cylinders are running rich. if it is all of them, then it might be something electrical, but if it is only a few of them, it is probably something internal. I had this type of problem too. Took the truck to an electrical place and they said it was fine. I changed all the things you did too. It turned out to be 2 bad valves and bad valve guides. so i had those replaced and it runs good, no problems like i had before. it was kind of bad news to hear that i had bad valves, but it was nice to finally know what the problem was.
hope this helps

Craig

'89 S-10 P/U 4.3L 31" Yoko M/Ts (For Sale!)[img]/wwwthreads_images/icons/shocked.gif[/img]
'99 S-10 2.2L 2WD 5 Speed Totally Stock [img]/wwwthreads_images/icons/frown.gif[/img]

'88 Kawasaki Mojave (FOR SALE)[img]/wwwthreads_images/icons/cool.gif[/img]
Fishyoo7 is offline  
post #3 of (permalink) Old 03-10-2001, 08:42 PM
**DONOTDELETE**
Guest
 
Posts: n/a
Re: 91 S10 that sputters & Jerks??

Boy does this sound familiar..mine was running great,but after sending it to the shop that does 4x4's for new plugs and wires(i work 17 hours a day for a while or would have done it myself)and now it runs like crap..spit sputter and jerks..they cant find nothing and I cant either..they (CLEANED)my air idea speed sensor..and boom.
but it sound to me and im looking on mine for a short in a throttle pos senson..it's seams realated to the computer..also does your temp gauge look like you running warmer than normal.. not hot just a little warmer..
I think theres a tie in between the temp sensor and TPS,and when the motor is colder its reading warmer and changing the fuel that the truck actually needs. The motor temp is say 90 to 100deg. and the comp is reading 160..
Just a thought

http://members.theglobe.com/moneysti...ght/22_19A.JPG
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Off-Road Forums & Discussion Groups forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome