Crazy Oil Pressure Problem!! - Off-Road Forums & Discussion Groups
GM Small Trucks & SUV's All discussion of S-Class Trucks and SUV's

 
LinkBack Thread Tools Display Modes
post #1 of (permalink) Old 02-12-2001, 08:51 PM
**DONOTDELETE**
Guest
 
Posts: n/a
Crazy Oil Pressure Problem!!

When in Park or neutral, the oil pressure is between 40 and 80. When I put it in OD, D, etc, it drops almost to zero! As long as I am in motion, it is fine. If I come to a stop lite, I can watch it drop as I slow, all the way down almost to zero. It is a 2.8, 1987, 4x4, Auto. When I gain speed, it never goes higher than say, 60(between 40-80), so thats cool, but when I slow down under 15 mph it happens, so at stops I drop er into N, and its fine, it goes back up. Thats all folks!!

Sponsored Links
Advertisement
 
post #2 of (permalink) Old 02-13-2001, 11:11 AM
 
Join Date: Mar 2000
Posts: 1,623
Thanks: 0
Thanked 0 Times in 0 Posts
 
Re: Crazy Oil Pressure Problem!!

Sounds like your engine is getting tired, try a thicker oil

Scooby Dooby Doo !!!
Scoobydoo is offline  
post #3 of (permalink) Old 02-14-2001, 09:46 PM
**DONOTDELETE**
Guest
 
Posts: n/a
Re: Crazy Oil Pressure Problem!!

I have the same problem with my 87 tahoe... I also want to know what the hell it is????????????????????????

Sponsored Links
Advertisement
 
post #4 of (permalink) Old 02-14-2001, 10:23 PM
 
Join Date: Sep 1999
Posts: 6,517
Thanks: 0
Thanked 0 Times in 0 Posts
 
Re: Crazy Oil Pressure Problem!!

<font face="Comic Sans MS">The electric oil pressure senders in these trucks are horribly inaccurate (actually holds true for most electronic pressure senders. Example:
my 85 reads about 10 at slow idle and pegs when the engine is over 1500-2000 rpms. Bottom line? Bad sender. As long as it registers some pressure at all I wouldn't be worried about it.

If you want a real accurate reading of oil pressure, get yourself a good quality mechanical guage. </font>

Tim "Sandman"

ORC Land Use columnist:
My November article on ORC
The_Sandman_454 is offline  
post #5 of (permalink) Old 02-20-2001, 07:23 PM
**DONOTDELETE**
Guest
 
Posts: n/a
Re: Crazy Oil Pressure Problem!!

I have the same problem in mine. It only happens when my engine is up to temp. When my engine goes down to an idle my pressure drops to ZERO! I sit at stop lights with my foot on the gas. [img]/wwwthreads_images/icons/smile.gif[/img] I have an '86 2.8 that has just under 30K.

Ben [img]/wwwthreads_images/icons/smile.gif[/img]
post #6 of (permalink) Old 02-21-2001, 09:02 AM
Pooh-Bah
 
Join Date: Jan 2000
Location: San Diego, CA
Posts: 1,623
Thanks: 0
Thanked 0 Times in 0 Posts
 
Re: Crazy Oil Pressure Problem!!

Every motor I've ever had have dropped close to zero at idle when hot, especially after some time on the freeway. A big help is an oil cooler. It doesn't hurt to run a good free flowing filter too, I run AC Ultra-gaurd.

If anyone finds a cure, if there is one, I'd like to hear it too!

Chevota
chevota is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Off-Road Forums & Discussion Groups forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome