Help my blazer - Off-Road Forums & Discussion Groups
GM Small Trucks & SUV's All discussion of S-Class Trucks and SUV's

 
LinkBack Thread Tools Display Modes
post #1 of (permalink) Old 10-23-2000, 06:54 PM
**DONOTDELETE**
Guest
 
Posts: n/a
Help my blazer

I have a 95 blazer and it is running horible. it starts hard, idles rough and coughs and sputters when I drive at all speeds. i was told it was the injector controls on the top of the motor, is this true.
thanks

Sponsored Links
Advertisement
 
post #2 of (permalink) Old 10-23-2000, 08:22 PM
 
Join Date: Sep 1999
Posts: 2,135
Thanks: 0
Thanked 0 Times in 0 Posts
 
Re: Help my blazer

It's totally possible. The single injector thing has always had me bewildered... If it's not bad, then it might just need a thorough cleaning. I would also go and check out the O2 sensor, as that seems to be the cause of a lot of problems on S-10's...

Hope that helps.

J.R. [img]/wwwthreads_images/icons/cool.gif[/img]

http://members.xoom.com/desertride/index.htm
J.R. is offline  
post #3 of (permalink) Old 10-23-2000, 11:03 PM
 
Join Date: Sep 1999
Posts: 6,517
Thanks: 0
Thanked 0 Times in 0 Posts
 
Re: Help my blazer

Throttle position sensor could do that... If it senses the wrong throttle position it'll either flood the engine or starve it for fuel since it'd be tricking the computer into thinking it had more or less throttle than it should. [img]/wwwthreads_images/icons/crazy.gif[/img] But then again I'm not the injection guru either... [img]/wwwthreads_images/icons/crazy.gif[/img]

Tim
ORC Land Use columnist
My August article on ORC

http://www.off-road.com/land
The_Sandman_454 is offline  
Sponsored Links
Advertisement
 
post #4 of (permalink) Old 10-24-2000, 08:17 AM
 
Join Date: Jun 2000
Posts: 230
Thanks: 0
Thanked 0 Times in 0 Posts
 
Re: Help my blazer

These particular motors are very sensitive to fuel pressure, and can cause the problems that your talking about. I would check that first. The injectors are also very prone to go bad. They came out with an improved one.
David G.

'91 S15 Jimmy 5.7L 4X4
Blazernut is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Off-Road Forums & Discussion Groups forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome