small s-10 srange problem - Off-Road Forums & Discussion Groups
GM Small Trucks & SUV's All discussion of S-Class Trucks and SUV's

 
LinkBack Thread Tools Display Modes
post #1 of (permalink) Old 08-03-2005, 02:23 AM
kc2dzt
Guest
 
Posts: n/a
small s-10 srange problem

i have a s 10 blazer 4x4 with a 2.8 l motor . it has develope a problem . when up to temp runs fine untill u tap the brakes . idles at 1000 , when i step on breaks . idle goes 2200 . replaced egr valve map senser ect changed cap rotor wires still same problem .... also checked power brake booster and check valve ... no leaks.. i think this is a tough one.. i may have to goto dealer EEEEEW anyone got a spare arm or a leg to donate ?? any help would be nice


email direct at
[email protected] [img]/ubbthreads/images/graemlins/confused.gif[/img]
Sponsored Links
Advertisement
 
post #2 of (permalink) Old 08-03-2005, 08:02 PM
Apprentice
 
beekilla's Avatar
 
Join Date: Apr 2005
Location: North Wilkesboro, NC
Posts: 94
Thanks: 0
Thanked 0 Times in 0 Posts
 
Re: small s-10 srange problem

Are you sure the booster isn't leaking? Not trying to be a smarty pants at all...just wondering. The diaphragm obviously isn't leaking (or at least very little) while the brakes are not depressed, but how do you know that the now moving mechanism isn't leaking when the pedal is pressed? Have a friend help to find the leak using WD40?
beekilla is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Off-Road Forums & Discussion Groups forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome