Low oil pressure - Off-Road Forums & Discussion Groups
GM Small Trucks & SUV's All discussion of S-Class Trucks and SUV's

 
LinkBack Thread Tools Display Modes
post #1 of (permalink) Old 04-07-2004, 10:26 AM
FishinCC
Guest
 
Posts: n/a
Low oil pressure

Well, I put a new tranny into my '85 Blazer, and it runs fine, except that the indicated oil pressure is way low - under 10 psi on a highway, and drops when lights are on (gotta be an electrical bug). No other signs of oil starvation, too. Has anybody seen that before? Man, I miss the olden days of idiot lights that give you binary info: "OK - screwed"...
Sponsored Links
Advertisement
 
post #2 of (permalink) Old 04-09-2004, 10:57 PM
 
Join Date: Oct 2003
Posts: 52
Thanks: 0
Thanked 0 Times in 0 Posts
 
Re: Low oil pressure

replace your oil sender.
daytona is offline  
post #3 of (permalink) Old 04-26-2004, 10:26 AM
gmcstep
Guest
 
Posts: n/a
Re: Low oil pressure

I conqure with daytona my 92 s10 did the same thing
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Off-Road Forums & Discussion Groups forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome