Sonoma Electronic 4x4 problems - Off-Road Forums & Discussion Groups
GM Small Trucks & SUV's All discussion of S-Class Trucks and SUV's

 
LinkBack Thread Tools Display Modes
post #1 of (permalink) Old 02-24-2004, 11:46 PM
Blizzake
Guest
 
Posts: n/a
Sonoma Electronic 4x4 problems

I have a 94 Sonoma S15 4x4 ZR2 with electronic 4x4, the selector switch will not transfer it into 4 high or 4 low, or if it ever does it only works for a short period of time.

Sometimes the light will go off on the 2 high button as well.

I have changed the vacuum check valve and it's pretty aparent that vacuum is not the problem.

Could it be the transfer case control module?

Has anyone experienced any similar problems?

Any help is apreciated.

-Blake.
Sponsored Links
Advertisement
 
post #2 of (permalink) Old 02-26-2004, 08:06 AM
 
Join Date: May 2003
Posts: 244
Thanks: 0
Thanked 0 Times in 0 Posts
 
Re: Sonoma Electronic 4x4 problems

You mean the 4Hi button instead of the 2high button. I have a 93 blazer and there is no 2hi button. Sorry but I haven't had the problem before and I'm not familiar with the NP243 xfer case so I can't help you. Does it actually try to go into 4 wheel drive then jump out? I would start by checking voltages and grounds. I would assume there has to be an electrical circuit controlling the vacuum actuator which is controlled by the push button.

Good luck and let me know if you find anything.

blabhern is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Off-Road Forums & Discussion Groups forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome