91 sonoma 4.3 into an 86 s-10 2.8 - Off-Road Forums & Discussion Groups
GM Small Trucks & SUV's All discussion of S-Class Trucks and SUV's

 
LinkBack Thread Tools Display Modes
post #1 of (permalink) Old 03-19-2003, 03:51 PM
**DONOTDELETE**
Guest
 
Posts: n/a
91 sonoma 4.3 into an 86 s-10 2.8

Hello.I am new here and I have some questions.

My first truck was a 1991 gmc sonoma st.It was 4wd extended cab.It had the tbi 4.3 and 700r4 trans.Unfortuanitly I tottalled it last july.I still have it though.

I just purchased a s-10 that is extended cab 4wd.I am not sure on the year.It is an 86 I believe.(I bought it from my buddies brother in law for a killer price)It used to have a 2.8 with a 5 speed.I am wanting to swap my 4.3 in it.While still keeping the 5 speed.It is my understanding the 4.3's had the same bell housing bolt pattern as the v-8's.And the 2.8's had a different one.Am I correct.If so how hard is it to find a 5 speed for the 4.3 that a transfercase bolts up to.


Thanks for any help.
Sponsored Links
Advertisement
 
post #2 of (permalink) Old 03-19-2003, 09:02 PM
**DONOTDELETE**
Guest
 
Posts: n/a
Re: 91 sonoma 4.3 into an 86 s-10 2.8

I talked to the owner and it is an 87.They are pulling the motor out to put in a camaro.

I should be picking it up this weekend.He claims the motor should bolt right up.I am thinking the wiring should be close.I will probably end up using my computer.

I can't wait to have another truck again.I loved that little thing.Went anywhere I wanted to go.Except one spot where I had to get pulled out by a(cough dodge cough)
post #3 of (permalink) Old 03-20-2003, 04:10 PM
Addict
 
gottagofast's Avatar
 
Join Date: Nov 2002
Location: louisville
Posts: 512
Thanks: 0
Thanked 0 Times in 0 Posts
 
Re: 91 sonoma 4.3 into an 86 s-10 2.8

bellhousing is different wiring is the same if you have tbi and not cpi on the wrecked truck (my 92 has cpi) but you need the computer prom from the 4.3 although it may run ok with the 2.8 chip you will probably not get as many mpg or hp ..... i once put the comp and prom from my 2.8 87 s-10 in my 5.7 88 suburban just for the heck of it ... i could not tell the difference and it seemed to run perfect but i only drove it about 10 mi
gottagofast is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Off-Road Forums & Discussion Groups forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome