Misfire at all speeds... don't know the cause - Off-Road Forums & Discussion Groups
GM Small Trucks & SUV's All discussion of S-Class Trucks and SUV's

 
LinkBack Thread Tools Display Modes
post #1 of (permalink) Old 08-26-2002, 04:45 PM Thread Starter
 
Join Date: Sep 2001
Posts: 250
Thanks: 0
Thanked 0 Times in 0 Posts
 
Misfire at all speeds... don\'t know the cause

I'm from California and it's smog check time for my 90 S-10 4.3L. Last time I had it smogged the tech struggled to get it to pass. I did all the necessary prep, tune-up, oil change, air filter, etc. The tech said it misfired at all speeds and had high volume of unburned hydrocarbon coming out of the pipe.

It's been two years now and I gotta get it smogged. Any suggestions as to the cause? The poor beast has 275K+ on the odometer.

Thanks.
Ragtag is offline  
Sponsored Links
Advertisement
 
post #2 of (permalink) Old 08-26-2002, 07:00 PM
 
Join Date: Sep 1999
Posts: 2,135
Thanks: 0
Thanked 0 Times in 0 Posts
 
Re: Misfire at all speeds... don\'t know the cause

I would start by doing a compression test on the cylinders. Then see if you need to get your valves adjusted.

From there try and see if your EGR valve is whacked.

Then maybe sensor replacement, like the 02 sensors...

HTH
J.R. is offline  
post #3 of (permalink) Old 08-27-2002, 10:28 AM Thread Starter
 
Join Date: Sep 2001
Posts: 250
Thanks: 0
Thanked 0 Times in 0 Posts
 
Re: Misfire at all speeds... don\'t know the cause

Thanks J.R.



Roger
Ragtag is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Off-Road Forums & Discussion Groups forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome