87' 2.8 problem - Off-Road Forums & Discussion Groups
GM Small Trucks & SUV's All discussion of S-Class Trucks and SUV's

 
LinkBack Thread Tools Display Modes
post #1 of (permalink) Old 03-28-2000, 07:58 PM Thread Starter
 
Join Date: Dec 1999
Posts: 531
Thanks: 0
Thanked 0 Times in 0 Posts
 
87\' 2.8 problem

The truck leaks motor oil bad when parked uphill. parked on flatland leak is non to slight. appears to be coming from backside of motor
going to check it out in the A.M. Anyone else had this happen before?

slowpoke is offline  
Sponsored Links
Advertisement
 
post #2 of (permalink) Old 03-28-2000, 10:09 PM
 
Join Date: Sep 1999
Posts: 2,135
Thanks: 0
Thanked 0 Times in 0 Posts
 
Re: 87\' 2.8 problem

Can you locate where the leak is coming from directly? It could be something as simple as having to tighten up the oil pan, or it could be the dreaded rear main seal on you motor.

Get it all cleaned up and then try to locate the source of the oil.

J.R. [img]/wwwthreads_images/icons/cool.gif[/img]
My Web Page
J.R. is offline  
post #3 of (permalink) Old 03-28-2000, 11:38 PM
**DONOTDELETE**
Guest
 
Posts: n/a
Re: 87\' 2.8 problem

Reach in back of the engine, from the top, next to the Distributor. You're looking for the intake manifold gasket to be sticking out from between the manifold and block. (That's why I'm going ahead and doing the 4.3 Throttle body swap. I figure that while I've got the manifold off, I might as well do the machine work on the manifold...)

Anyway, that's where mine's leaking, after 254,000 miles....



Sponsored Links
Advertisement
 
post #4 of (permalink) Old 03-30-2000, 04:59 PM
**DONOTDELETE**
Guest
 
Posts: n/a
Re: 87\' 2.8 problem

Ya, what Warren said the front and rear seals on the intake is RTV
dries out, crack,seperates whatever it leaks. Also the rocker covers
and dist seal are very common
(I think I just said that)
Later

HAWG WILD
<font color=red> ALL THOSE WHO WANDER ARE NOT NECESSARLY LOST </font color=red> [img]/wwwthreads_images/icons/cool.gif[/img]
post #5 of (permalink) Old 03-30-2000, 11:41 PM Thread Starter
 
Join Date: Dec 1999
Posts: 531
Thanks: 0
Thanked 0 Times in 0 Posts
 
Re: 87\' 2.8 problem

thanks for the tips, still have not had time to check it yet. definetly going to this weekend.

slowpoke is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Off-Road Forums & Discussion Groups forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome