Slow Traffic - Off-Road Forums & Discussion Groups
Ford Early Bronco, 66-77 All discussion of Early Ford Bronco's to 1977

 
LinkBack Thread Tools Display Modes
post #1 of (permalink) Old 08-08-2000, 06:12 AM
**DONOTDELETE**
Guest
 
Posts: n/a
Slow Traffic

I noticed traffic was slow on this bboard.I think it is cause it is not to user friendly.I dont want to step on toes but I want to let everyone know I started a new message board that is a little easier to work .You will need a user name and password that in the hardiest part of reading and posting. It also has a chat room .If anyone wants to check it out here is where it is.I just made it so it looks empty right now .
http://www.delphi.com/EarlyBroncos/start
Later
Nick

Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Off-Road Forums & Discussion Groups forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome