Urgent, Please help !!!!!!!!!!! - Off-Road Forums & Discussion Groups
Ford 67-96 F-Series, 78-96 Bronco All discussions of 67-96 F-Series Trucks and 78-96 Broncos

 
LinkBack Thread Tools Display Modes
post #1 of (permalink) Old 02-14-2001, 11:52 PM
**DONOTDELETE**
Guest
 
Posts: n/a
Urgent, Please help !!!!!!!!!!!

Tonight I tried to start up my truck but all I heard was the starter( I think it was the starter), The sound was Click, Click, Click. My lights ans everything work and I just recharged the battery and put it back in today. Please help me, I NEED the mud!!!!!

"Yeah I remember her saying, I'm already dead"
Sponsored Links
Advertisement
 
post #2 of (permalink) Old 02-15-2001, 12:19 AM
Mud in my Veins
 
muddybronco's Avatar
 
Join Date: Oct 1999
Location: woooooo pig sooooooie!
Posts: 6,842
Thanks: 0
Thanked 0 Times in 0 Posts
 
Re: Urgent, Please help !!!!!!!!!!!

Sounds like bad starter. Have somebody beat on it with a wrench or similar while you crank it. Mine started for awhile after mine first went out by doing this. You can always just take it off and have it tested at autozone or something. What I've noticed is that the muddy water gets grit into the bearings inside there and ruins them. I took mine apart and good lord it all just fell apart. Put it back together and traded it towards a $120 lifetime replacement one.

It's a Jeep thing? My Bronco thing will run over your little Jeep thing.

Muddybronco
muddybronco is offline  
post #3 of (permalink) Old 02-15-2001, 09:07 AM
**DONOTDELETE**
Guest
 
Posts: n/a
Re: Urgent, Please help !!!!!!!!!!!

Before replacing the starter, make sure all wires attatched to the starter and the Battery have a good clean connection. My 93 had a rusty loose connection attached to the starter and the truck acted the same way sometimes when I tried to start it. I replaced the connector and everything works fine.


RidingHigh's stable
93 Bronco Eddie 302 32 BFG AT Warn Prem (this is the only transportation I currently have)
98 Chev Suburban LT 350 (current problems stated)
68 Pontiac Firebird 400 (current frame off resto taking place)
85 Hydra-sport 22ft DC..96' 200Merc EFI (my other hobby)


Sponsored Links
Advertisement
 
post #4 of (permalink) Old 02-15-2001, 01:31 PM
**DONOTDELETE**
Guest
 
Posts: n/a
Re: Urgent, Please help !!!!!!!!!!!

Why did you have to recharge the battery? Get a volt meter, and measure the voltage across the posts. It will probably show 12V, give or take. Have someone try to start the truck while you keep the meter attached to the posts. If the voltage drops to 10 or less, you have at least one bad cell. Time for a new battery.

post #5 of (permalink) Old 02-15-2001, 03:58 PM
**DONOTDELETE**
Guest
 
Posts: n/a
Re: Urgent, Please help !!!!!!!!!!!

if you can start it with a jump the battery is bad. if not
i would start by changed the solinoid.


post #6 of (permalink) Old 02-15-2001, 04:38 PM
**DONOTDELETE**
Guest
 
Posts: n/a
Re: Urgent, Please help !!!!!!!!!!!

Thanks guys. It was just a couple of loose wires. thanks
Later



"Yeah I remember her saying, I'm already dead"
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Off-Road Forums & Discussion Groups forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome