300 six stumbles - Off-Road Forums & Discussion Groups
Ford 67-96 F-Series, 78-96 Bronco All discussions of 67-96 F-Series Trucks and 78-96 Broncos

 
LinkBack Thread Tools Display Modes
post #1 of (permalink) Old 12-04-2005, 04:41 PM Thread Starter
Newbie
 
Join Date: May 2004
Posts: 23
Thanks: 0
Thanked 0 Times in 0 Posts
 
300 six stumbles

I forgot to ask this in my other post. It's still the same 1990 f-150 and it stumbles when it's idling. Not all the time but once every couple minutes. Also i changed the plug's and they are white looking. would't this be a lean condition or do all the efi 300's run like this?
sexman is offline  
Sponsored Links
Advertisement
 
post #2 of (permalink) Old 04-17-2009, 04:24 PM
 
Join Date: Apr 2009
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
 
91 f-150

I have a 91' w/ 300 and have the same problems. I have linked the white spark plugs to overheating, not sure if this is whats causing your problems but could be an idea. And as far as stumbling at an idle, pretty much the entire stock fuel delivery system is suffering, ive seen injector and hose replacement fix the problem. Mine will stumble and bog when in gear but due to a tranny about 10k miles past needing to be replaced.
AKford is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Off-Road Forums & Discussion Groups forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome