Engine mounts - Off-Road Forums & Discussion Groups
Ford 67-96 F-Series, 78-96 Bronco All discussions of 67-96 F-Series Trucks and 78-96 Broncos

 
LinkBack Thread Tools Display Modes
post #1 of (permalink) Old 07-28-2005, 04:03 PM Thread Starter
esm
 
Join Date: Mar 2002
Posts: 117
Thanks: 0
Thanked 0 Times in 0 Posts
 
Engine mounts

Hey,

Does anyone know a good source for engine mounts for a '96 302 Bronco?

Thanks,

Ed
esm is offline  
Sponsored Links
Advertisement
 
post #2 of (permalink) Old 07-29-2005, 01:32 AM
BOLT
Guest
 
Posts: n/a
Re: Engine mounts

Autofab.com
post #3 of (permalink) Old 07-30-2005, 02:16 PM Thread Starter
esm
 
Join Date: Mar 2002
Posts: 117
Thanks: 0
Thanked 0 Times in 0 Posts
 
Re: Engine mounts

Thanks, they are a wee bit pricey, though.
esm is offline  
Sponsored Links
Advertisement
 
post #4 of (permalink) Old 07-31-2005, 11:11 AM
BOLT
Guest
 
Posts: n/a
Re: Engine mounts

OK... Pep Boys, Autozone, Kragens, Walmart...
post #5 of (permalink) Old 07-31-2005, 12:02 PM
 
Join Date: May 2003
Posts: 1,344
Thanks: 0
Thanked 0 Times in 0 Posts
 
Re: Engine mounts

Motor mounts at WalMart, eh?
GTRider245 is offline  
post #6 of (permalink) Old 07-31-2005, 02:29 PM
BOLT
Guest
 
Posts: n/a
Re: Engine mounts

Why not... they sell $400 a piece BFG Baja TAs... who knows... Point being he asked for good mounts... I gave him good mounts then he wanted cheap... so I gave him cheap...
post #7 of (permalink) Old 08-01-2005, 03:38 PM Thread Starter
esm
 
Join Date: Mar 2002
Posts: 117
Thanks: 0
Thanked 0 Times in 0 Posts
 
Re: Engine mounts

Thanks for providing the "good mounts" info. I got them at CarQuest for $34/change a piece. What's "better" with those expensive mounts, does the Bronco drive differently with them?
esm is offline  
post #8 of (permalink) Old 08-22-2005, 09:26 AM Thread Starter
esm
 
Join Date: Mar 2002
Posts: 117
Thanks: 0
Thanked 0 Times in 0 Posts
 
Re: Engine mounts

Hi,

I finally got my engine mounts. Since I've never exchanged them before, are there any particular procedures to follow?

Thanks,

Ed
esm is offline  
post #9 of (permalink) Old 08-27-2005, 11:57 PM
steveG3
Guest
 
Posts: n/a
Re: Engine mounts

I put autofab engine mounts and transmission mount on my old Explorer and they were great. They held the motor in place like a solid mount but still absorbed a lot of the vibrations bcause of the bushing design. There's a good suggestion on Autofab's website. John types something like "take your hood off and see how much your motor moves while off-road...." I did and man was that thing flopping around when I was driving through rough sections.

They're a lot more than stock mounts, but you get a lot more. If you buy them, they'll be the last set of engine mounts you'll buy for your truck.
post #10 of (permalink) Old 08-28-2005, 11:03 AM Thread Starter
esm
 
Join Date: Mar 2002
Posts: 117
Thanks: 0
Thanked 0 Times in 0 Posts
 
Re: Engine mounts

I've already got a set of mounts from CarQuest and I'd like to find out if there are any "special" procedures to follow when replacing those things? I've never done it before.

Thanks,

Ed
esm is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Off-Road Forums & Discussion Groups forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome