87 Bronco major issues - Off-Road Forums & Discussion Groups
Ford 67-96 F-Series, 78-96 Bronco All discussions of 67-96 F-Series Trucks and 78-96 Broncos

 
LinkBack Thread Tools Display Modes
post #1 of (permalink) Old 11-04-2004, 11:46 AM
blusoul
Guest
 
Posts: n/a
87 Bronco major issues

Hello
I have an 1987 Bronco XLT. Recently it has been doing things that have me worried. Let me start about two weeks ago the starter went out (I guess) so I got that replaced, my truck was starting fine for about two days then all hell broke loose it would start but cut off if I do not have my foot on the gas it seems to be having trouble gearing up and to make matters worst it is reved up (when my foot is on the brake it want to go, it jerks) oh yea and it makes some noise. It idles funny so it it gets too low it will cut off it will stay on as long as it stays in the 1 area but below it it cuts off. I am afraid to take it to the mechanic because they are going to tell me anything they can to get more money out of me than necassary so I would like to go with some general knowledge of the possible issue. One more thing when the starter went bad In order for it to start I had the (spelled wrong) seliniod shocked and it started right up.
Please help me
Sponsored Links
Advertisement
 
post #2 of (permalink) Old 11-05-2004, 12:25 PM
Bull
Guest
 
Posts: n/a
Re: 87 Bronco major issues

Sounds like an electrical problem IMO. I would check your starter relay, alternator wiring, and primary wire from your battery.
I had a similar problem when my alternator primary wire melted...weird idle, dying when idle dropped too low and running rough. A short or drop in ampacity from your electrical system can cause big problems with the computer that mimicks other problems.
Maybe something got too hot when your starter fried???

Bull
post #3 of (permalink) Old 11-05-2004, 01:17 PM
 
Join Date: Feb 2004
Posts: 373
Thanks: 0
Thanked 0 Times in 0 Posts
 
Re: 87 Bronco major issues

If that does not work I would check for trouble codes. Alot of times a code will lead you to find a bad connection or a bad vacuum line.
Jacob_Royer is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Off-Road Forums & Discussion Groups forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome