i have a E4OD transmission in a 90 xlt bronco help - Off-Road Forums & Discussion Groups
Ford 67-96 F-Series, 78-96 Bronco All discussions of 67-96 F-Series Trucks and 78-96 Broncos

 
LinkBack Thread Tools Display Modes
post #1 of (permalink) Old 04-30-2003, 10:28 PM Thread Starter
 
Join Date: Feb 2003
Posts: 237
Thanks: 0
Thanked 0 Times in 0 Posts
 
i have a E4OD transmission in a 90 xlt bronco help

can anyone tell me how to adjust the kickdown on these tranny's? i can drive down the road fairly normal- but as soon as i go to stomp the peddle to the floor, it whines out & i have to back off to get it to upshift. i can come to a stop by downshifting manualy & the tranny works like it should...from a stand still it will shift from park to drive without any slipping...so it just seems to me?- that it's the kick down NOT WORKING! HELP ME SOMEONE... the haynes manual sucks...i got to quit buying them. [img]images/graemlins/confused.gif[/img] [img]images/graemlins/scs.gif[/img]
zukpirate is offline  
Sponsored Links
Advertisement
 
post #2 of (permalink) Old 04-30-2003, 10:47 PM
BigOrangeBronco
Guest
 
Posts: n/a
Re: i have a E4OD transmission in a 90 xlt bronco help

The E in E4OD stands for electronic. This means the shift points are controlled by the ECM. The later E4OD system, (that includes the ECM), has revised shift points. You may want to try one of the aftermarket shift controllers. Try Baumann engineering's website.
post #3 of (permalink) Old 05-01-2003, 08:47 AM
Shilo
Guest
 
Posts: n/a
Re: i have a E4OD transmission in a 90 xlt bronco help

Yep, live with it or rebuild it.

When mine got bad it wouldn't drop to 3rd on the highway until like 50mph, no matter how much I mashed the pedal.
Sponsored Links
Advertisement
 
post #4 of (permalink) Old 05-01-2003, 02:53 PM
Novice
 
Join Date: Nov 2002
Location: Arvada, CO
Posts: 30
Thanks: 0
Thanked 0 Times in 0 Posts
 
Re: i have a E4OD transmission in a 90 xlt bronco help

Mine was behaving strangely, several years ago. Similar to what you describe. Turned out to be a blown fuse, on the ECM.
Did yours start behaving this way, suddenly or over a period of time?
firegod33 is offline  
post #5 of (permalink) Old 05-01-2003, 10:42 PM Thread Starter
 
Join Date: Feb 2003
Posts: 237
Thanks: 0
Thanked 0 Times in 0 Posts
 
Re: i have a E4OD transmission in a 90 xlt bronco help

my tranny just out of the clear blue started acting up! i admit i was puddle hop'ing...must of got all the electrical connectors wet/go figure? it acts normal today...so i changed the fluid & slapped a new filter & gasket on it.everything seems great...one wierd scene man. [img]images/graemlins/scs.gif[/img]
zukpirate is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Off-Road Forums & Discussion Groups forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome