Idle probs for 90 - Off-Road Forums & Discussion Groups
Ford 67-96 F-Series, 78-96 Bronco All discussions of 67-96 F-Series Trucks and 78-96 Broncos

 
LinkBack Thread Tools Display Modes
post #1 of (permalink) Old 05-23-2000, 03:57 PM
**DONOTDELETE**
Guest
 
Posts: n/a
Idle probs for 90

I have a 90 Bronco with 302 and a five speed manual tranny. Sometimes the idle will not come down to lower than 2,000-2,500 rpm. This usually occurs after 10 to 20 mins of driving especially at highway speeds. It happens less frequently on short trips. Sometimes I can get it to come down to normal if I rev it to 5,000rpms or so and then let off. At start up idle is smooth and at around 750rpm. What could be causing this? It is extremely agravating and makes driving difficult at times. Any help you guys can give me would be greatly apreciated. Thanks in advance

Sponsored Links
Advertisement
 
post #2 of (permalink) Old 05-25-2000, 09:38 PM
**DONOTDELETE**
Guest
 
Posts: n/a
Re: Idle probs for 90

THe only thing that I can think of that might cause that problem if it is not a sticking throttle linkage maybe that TPS, throttle position sensor, is sticking or reading incorrectly and it is not telling the computer that you have throttled down so the computer is still sending extra gas to the cylinders. Have you scanned your computer codes. That will ussually tell you which sensor is bad.

[img]/wwwthreads_images/icons/cool.gif[/img] MG48 - 88 Bronco
post #3 of (permalink) Old 05-25-2000, 09:59 PM
**DONOTDELETE**
Guest
 
Posts: n/a
Re: Idle probs for 90

You also might want to check your temperature sensor. It might not be telling the computer that the engine has warmed up and is still running rich.

Later,
Bravoman


What the hell, go for broke or my case broken!
Sponsored Links
Advertisement
 
post #4 of (permalink) Old 06-08-2000, 11:57 PM
**DONOTDELETE**
Guest
 
Posts: n/a
Re: Idle probs for 90

tune it up, clean you throttle body and check/change your idle air motor. worked for me........ Now if I can find out why I am loosing power once my motor has warmed up, I'll be great.

"Mess with the Bull and you shall get the horn"
post #5 of (permalink) Old 07-02-2000, 02:22 AM
**DONOTDELETE**
Guest
 
Posts: n/a
Re: Idle probs for 90

It will either be a throttle position sensor or the iac solenoid sticking.Norman

Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Off-Road Forums & Discussion Groups forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome