foot of water in interior of 93...stuck in 4lo..HELP :) - Off-Road Forums & Discussion Groups
Ford 67-96 F-Series, 78-96 Bronco All discussions of 67-96 F-Series Trucks and 78-96 Broncos

 
LinkBack Thread Tools Display Modes
post #1 of (permalink) Old 04-28-2000, 11:28 PM Thread Starter
Mud in my Veins
 
muddybronco's Avatar
 
Join Date: Oct 1999
Location: woooooo pig sooooooie!
Posts: 6,842
Thanks: 0
Thanked 0 Times in 0 Posts
 
foot of water in interior of 93...stuck in 4lo..HELP :)

Well, I once again have dunked the bronco, but at least this time all my breather lines were run, so I have but one problem that I've found. The damn electronic 4wd is stuck in 4lo...and there aren't many 30mph zones around here. I had a foot of water in the passenger side, and if I remember right that is where I always here the clicking of the 4wd relay, so I'm sure it got a nice dowsing. I've had it drying out with the windows down for 2 days, and I'm going out tomorrow to see if it's working again. Problem is, it's half an hour from me and the parts store, so if the chances are good I'm going to have to replace something I'd like to know before I head out there. Anybody know what I would need to replace, if anything? Thanks.

muddybronco is offline  
Sponsored Links
Advertisement
 
post #2 of (permalink) Old 04-29-2000, 01:30 PM
**DONOTDELETE**
Guest
 
Posts: n/a
Re: foot of water in interior of 93...stuck in 4lo..HELP :)

If your 93 is like my 88, the relay for the electric shift is behind the passenger side kick panel. If you soaked it that is probably why it is stuck. I would disconnect the battery and remove the kick panel. Unplug the relay box and if possible, open it up to allow it to dry. These units are probably ford only and are very expensive (300.00 or 400.00 from Ford, I think).

post #3 of (permalink) Old 04-30-2000, 12:48 AM Thread Starter
Mud in my Veins
 
muddybronco's Avatar
 
Join Date: Oct 1999
Location: woooooo pig sooooooie!
Posts: 6,842
Thanks: 0
Thanked 0 Times in 0 Posts
 
Re: foot of water in interior of 93...stuck in 4lo..HELP :)

Good news...it works again. Apparently it just needed some quiet time. Now if i can just get the damn back window to go back up.


muddybronco is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Off-Road Forums & Discussion Groups forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome