Electrical glitches... Can anyone help with one or all? - Off-Road Forums & Discussion Groups
Ford 67-96 F-Series, 78-96 Bronco All discussions of 67-96 F-Series Trucks and 78-96 Broncos

 
LinkBack Thread Tools Display Modes
post #1 of (permalink) Old 12-29-1999, 09:45 PM
**DONOTDELETE**
Guest
 
Posts: n/a
Electrical glitches... Can anyone help with one or all?

I had the headlight/wiper switch panel off of my 88 to fix the wiper switch, and when I put it back together, my dash lights didn't work when the headlights were on. The only way my dash lights will work is if the switch is turned to the dome light position. I haven't been able to take it back apart, but I'm sure there is a bad connection or something. To top it all off, my wipers don't work any better than before! My list of question are... My interval setting doesn't work, and my wipers don't return to their home position when turned off. I went to the junkyard and got another switch, but they do the same thing. Someone told me that there is a relay that might cause the interval setting not to work, but that the motor is the only thing that would prevent them from going to their home position. I have to time it and turn them off, when they are down... I hope I don't have to replace the relay AND the motor! What happened to Quality is Job 1!!! Other electrical glitches include 3rd position on heater fan doesn't work (also replaced with another junkyard switch... Same thing!) dome light works, but little map lights don't (removed it, and maplights work when wired directly to battery) Rear window exterior switch doesn't work, but interior one does... I think that's it for now! Any help with any of these would be greatly appreciated... Oh Yea, all fuses appear to be fine, I don't know of any fusible links though. Thanks... I love machanical work, but chasing electrical bugs drives me insane!!!!

Sponsored Links
Advertisement
 
post #2 of (permalink) Old 12-30-1999, 12:14 AM
**DONOTDELETE**
Guest
 
Posts: n/a
Re: Electrical glitches... Can anyone help with one or all?

to start quality is job 1 but fords electrical is far from quality. Your wipers sound like they need a new relay box. it is quite easy to replace. its a black box with a red connector on it. it is right behind the wiper switch inside the dash. follow the wires back to it. you should not need a motor usually they work or don't work. the relay should cure it. the light problem is most likely a bad connection in the switch. ford headlight switches commonly burn up and go bad. your heater switch is most likely fine. the resistor coil is probably broken for the third position. this is where the blower motor plugs into usually on the plenum in the engine comp. to check, check the resistance between the coils. The rear window switch is either broken or the wires are coroded. a common place for them to corode is behind the rear taillamp at the connector or right under the brake booster in the engine comp. goodluck

post #3 of (permalink) Old 12-30-1999, 07:46 PM
**DONOTDELETE**
Guest
 
Posts: n/a
Thanks!

I'll give your suggestions a try this weekend. I didn't think the wiper motor would be the problem, and rust DEFINATELY could be the problem out back!

Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Off-Road Forums & Discussion Groups forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome