Just the battery going... or other problems? - Off-Road Forums & Discussion Groups
Ford 67-96 F-Series, 78-96 Bronco All discussions of 67-96 F-Series Trucks and 78-96 Broncos

 
LinkBack Thread Tools Display Modes
post #1 of (permalink) Old 01-02-2002, 12:36 PM
**DONOTDELETE**
Guest
 
Posts: n/a
Just the battery going... or other problems?

Hey folks,
The electrical stuff in the '83 has been acting up recently... real weird stuff like no turn signals but hazards, no radio, no heat blower, but headlights, and I can roll down the back window, no brights accessory lamp. Nothing real consistent either. The other day it wouldn't turn over at all, got a jump and started up fine. I'm going to replace the battery this week, but I'm wondering if its just the battery or if something else is shot... is there a way to test the alternator to see if it's charging? I've heard disconnect the battery when the truck is running... Any other suggestions? Its a carbed 300.

Thanks,
Ryan

Sponsored Links
Advertisement
 
post #2 of (permalink) Old 01-02-2002, 01:33 PM
Mud in my Veins
 
Steve83's Avatar
 
Join Date: Dec 2000
Location: Memphis, TN
Posts: 5,301
Thanks: 0
Thanked 0 Times in 0 Posts
 
Re: Just the battery going... or other problems?

That's generally a bad idea (especially on EFI's) - a better way is to simply check the voltage with the engine running. It should be between 13.5-15.5V if the alternator is working and the battery isn't totally dead. But the wierd array of non-functioning circuits suggests blown fuses or fusible links (the wires near the battery). Check a Haynes manual and see if the affected circuits share a fuse or fusible link and then check all of them. To check a fusible link (once you FIND it), gently pull from the ends - if the rubber stretches, the wire inside is burnt.


[email protected]
Steve83 is offline  
post #3 of (permalink) Old 01-02-2002, 02:47 PM
Shilo
Guest
 
Posts: n/a
Re: Just the battery going... or other problems?

Voltage regulator is another possibility.

Sponsored Links
Advertisement
 
post #4 of (permalink) Old 01-04-2002, 03:09 PM
**DONOTDELETE**
Guest
 
Posts: n/a
Re: Just the battery going... or other problems?

Today's update... just got the battery checked at lunch and its low (but good), going to have the alternator checked tonight which brings up the question - how long do alternators last? Don't know if this is the original one, but they degrade over time as opposed to just braking, don't they?

Thanks,
Ryan

post #5 of (permalink) Old 01-04-2002, 06:03 PM
Shilo
Guest
 
Posts: n/a
Re: Just the battery going... or other problems?

Yeah, alts will usually get weaker and weaker until they die out completely. But anything is possible. I don't think they have anything to do w/braking, but I suppose they could break :-)

Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Off-Road Forums & Discussion Groups forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome