1996 1500 with bad 318 magnum?????? - Off-Road Forums & Discussion Groups
Dodge 4x4 vehicles All discussion of Dodge trucks, Ramchargers, Plymouth and SUV's...

 
LinkBack Thread Tools Display Modes
post #1 of (permalink) Old 11-25-2009, 03:34 PM Thread Starter
Newbie
 
Join Date: May 2004
Posts: 23
Thanks: 0
Thanked 0 Times in 0 Posts
 
1996 1500 with bad 318 magnum??????

I've been helping this guy put new intake gaskets and timing chain in his truck. We also did the cap,rotor,plugs, and wires. Well, it runs but has no power and is alittle shakey at idle. We went over evrything on the ignition and checked the that the chain was put on right a few times. The only thing I can think of is a bent valve as the chain had jumped 4 teeth. What about bad injectors? He's had that happen before............
sexman is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Off-Road Forums & Discussion Groups forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome