86 CR500 problem w/ front brakes need help. - Off-Road Forums & Discussion Groups
Dirtbike Lounge Hang out and talk two wheels. For Tech and Racing specifically, see those forums below.

 
LinkBack Thread Tools Display Modes
post #1 of (permalink) Old 03-16-2003, 07:25 PM Thread Starter
 
Join Date: Feb 2003
Posts: 61
Thanks: 0
Thanked 0 Times in 0 Posts
 
86 CR500 problem w/ front brakes need help.

I am over from the jeep forum. Have a question about a 1986 CR500. At first the front brake was draging real bad (took two people to push it). Took the front tire off (the axel is fine). Opened the pads up put tire back on rolled fine. Hit the brakes they worked but started to drag again. Flushed out all the brake fluid and bled brakes. Now they will not pump back up. Any ideas would be very helpful.

Thank in advance.
opracer315 is offline  
Sponsored Links
Advertisement
 
post #2 of (permalink) Old 03-17-2003, 10:35 AM
Keyboard Implanted
 
Kyron's Avatar
 
Join Date: Aug 2000
Location: Peoria Az
Posts: 3,584
Thanks: 0
Thanked 0 Times in 0 Posts
 
Re: 86 CR500 problem w/ front brakes need help.

Clean the brake cyclinder, make sure the piston is really clean.........

Sounds to me like its getting hung up and not releasing [img]images/graemlins/confused.gif[/img]

Good luck [img]images/graemlins/burnout.gif[/img]
Kyron is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Off-Road Forums & Discussion Groups forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome