strange banshee behavior - Off-Road Forums & Discussion Groups
ATV Lounge Everything ATV - NOT defined in a specific forum below. Hang out with your friends.

 
LinkBack Thread Tools Display Modes
post #1 of (permalink) Old 07-18-2001, 10:32 PM Thread Starter
 
Join Date: Mar 2000
Posts: 2,439
Thanks: 0
Thanked 0 Times in 0 Posts
 
strange banshee behavior

here is the deal when we got the shee it was jetted rich (270 mains) so we took the airbox lid off and out a pro-flow in and it ran great then out riding one day and it just fell on its face and sputtered on the top end..put new plugs in and it didnt help so we thought maybe the high summer temps made it richer so we put in some 260 mains and it ran perfect again..so out riding and it started to sputter alittle so we let it sit for a while fired it up and it ran great..now today it ran great when it first started then the top end started to cut out again we asked a guy that races banshees at the dealer what he thought and he said that maybe the water impeller was melted so it would heat up and not run right..it still idles fine and starts up fine...so what are your thoughts on this? if you need more info ill see if i can explain more..its not fun riding a banshee with no power band..but it can still spin its tires on the road..hehehe

The only differnece between riders and animals is we arn't afraid of the vacuum cleaner.
<font color=blue>I'm 98Warrior but i have an 89Banshee too!</font color=blue>
98Warrior is offline  
Sponsored Links
Advertisement
 
post #2 of (permalink) Old 07-19-2001, 01:12 PM
**DONOTDELETE**
Guest
 
Posts: n/a
Re: strange banshee behavior

your slow jet and pilot jet might be ok, but mabye one of them is clogged? You said the airfilter is new right?


<font color=blue>Please, DON'T explain...</font color=blue>
post #3 of (permalink) Old 07-19-2001, 01:22 PM
cleartoy
Guest
 
Posts: n/a
Re: strange banshee behavior

You should have 300 mains with no lid and pipes.
Also 32.5 pilots.

The impeller could be melted. I put in a Pro Design stainless impeller to prevent any problems.

I assume the carbs are syncned up, and the plug wires are in good repair.

-cleartoy

Got sand?

Sponsored Links
Advertisement
 
post #4 of (permalink) Old 07-20-2001, 12:31 AM
raptor_rider
Guest
 
Posts: n/a
Re: strange banshee behavior

read the plugs if they are lean , check to make sure the vents on the carbs are clear, if they are plugged , it will run out of gas (or act like it ) which means it will idle fine but wont rev.

Ride hard, Lifes short
post #5 of (permalink) Old 07-20-2001, 03:51 PM Thread Starter
 
Join Date: Mar 2000
Posts: 2,439
Thanks: 0
Thanked 0 Times in 0 Posts
 
Re: strange banshee behavior

the carb breathers are the tubes coming out of the side of the carbs right?

The only differnece between riders and animals is we arn't afraid of the vacuum cleaner.
<font color=blue>I'm 98Warrior but i have an 89Banshee too!</font color=blue>
98Warrior is offline  
post #6 of (permalink) Old 07-20-2001, 06:01 PM
 
Join Date: May 2000
Posts: 2,173
Thanks: 0
Thanked 0 Times in 0 Posts
 
Re: strange banshee behavior

the vents he is talking about is the little plastic (usually clear) tubes that look like a breather tube. If they are clogged up it will cause a vacuum not allowing gas to flow correctly. but my first question...before you changed the jets...did u even look at the plugs???

If it is getting hot and losing power at high speeds or top end...it could be a headgasket leaking...do a compression check...check the water pump...and for bloody hell..check the plugs for how it is burning!!!!!!

oh...HI!!!


AirBorn!!
The good Lord giveth and the Eco-Nazi's Taketh away!
United we stand..Divided we fall..LETS UNITE!
AirBornBanshee is offline  
post #7 of (permalink) Old 07-20-2001, 08:43 PM Thread Starter
 
Join Date: Mar 2000
Posts: 2,439
Thanks: 0
Thanked 0 Times in 0 Posts
 
Re: strange banshee behavior

before we changed the jetting it didnt run worth crap so we didnt check the plugs becasue it seemed obvious that it was rich...then after we jetted they were darkish brown..ill check all these things you guys said...man the problem with these things is when somethings wrong it can be so many things!!!

The only differnece between riders and animals is we arn't afraid of the vacuum cleaner.
<font color=blue>I'm 98Warrior but i have an 89Banshee too!</font color=blue>
98Warrior is offline  
post #8 of (permalink) Old 07-20-2001, 09:50 PM Thread Starter
 
Join Date: Mar 2000
Posts: 2,439
Thanks: 0
Thanked 0 Times in 0 Posts
 
Re: strange banshee behavior

oh yeah and welcome back man!

<font color=blue>I own a Banshee. Fear me.</font color=blue>
98Warrior is offline  
post #9 of (permalink) Old 07-20-2001, 11:27 PM
 
Join Date: May 2000
Posts: 2,173
Thanks: 0
Thanked 0 Times in 0 Posts
 
Re: strange banshee behavior

Thanks!!!

AirBorn!!
The good Lord giveth and the Eco-Nazi's Taketh away!
United we stand..Divided we fall..LETS UNITE!
AirBornBanshee is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Off-Road Forums & Discussion Groups forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome