Cat engine Problem??? - Off-Road Forums & Discussion Groups
ATV Lounge Everything ATV - NOT defined in a specific forum below. Hang out with your friends.

 
LinkBack Thread Tools Display Modes
post #1 of (permalink) Old 02-16-2001, 08:56 PM
**DONOTDELETE**
Guest
 
Posts: n/a
Cat engine Problem???

I rode my 98 Cat 300 4x4 this week (in the snow) and right at the end of the day I had to limp it home cause it kept bogging and back firing every time I gave it a good shot of gas. Half throtle and over it would bog out and slow right down and start backfiring. What is wrong!!! This has never happened before. I put alot of hard use on it in the snow, could that be the problem?

Win if you can,
loose if you must but....
always cheat!
Sponsored Links
Advertisement
 
post #2 of (permalink) Old 02-17-2001, 03:19 AM
raptor_rider
Guest
 
Posts: n/a
Re: Cat engine Problem???

could have been trying to overheat, if you work them real hard in the snow they over rev and try to overheat, you have to be carefull not to run them to hard and you have to allow them to cool off slowly

Ride hard, Lifes short
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Off-Road Forums & Discussion Groups forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome