2006 Predator intermittent problem. pls help - Off-Road Forums & Discussion Groups
ATV Lounge Everything ATV - NOT defined in a specific forum below. Hang out with your friends.

 
LinkBack Thread Tools Display Modes
post #1 of (permalink) Old 07-12-2009, 09:16 PM Thread Starter
 
Join Date: Jul 2009
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
 
2006 Predator intermittent problem. pls help

So the only thing i did was change the oil (using the recommended PS4 synthetic oil and oem filter) and my crank case breather hose. Brought it for a test ride and it rode fine for about 15 mins. than all of a sudden i hit the throttle and it wants to die. Sometime's if i ease into it it goes. but if i clutch in or hammer it, it wants to die. I checked the oil and made sure nothing got in the crankcase filter hose or carb. everything looked clean as a whistle. Well went on leave and came back and rode it for the first time in 3 weeks yesterday. I let it warm up for 2 mins or so, cked the oil and it was good. So I took off and it rode great for about 15-20 mins. than the same thing started.... well this time it only lasted for 3-4 mins and than it rode perfect again. Can anyone shed any light on this for me? Gimme something to ck or troubleshoot please.
thanks in adavnce
a082185 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Off-Road Forums & Discussion Groups forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome