350 Odyssey - Off-Road Forums & Discussion Groups
ATV Lounge Everything ATV - NOT defined in a specific forum below. Hang out with your friends.

 
LinkBack Thread Tools Display Modes
post #1 of (permalink) Old 09-09-2005, 10:39 AM
Arnie
Guest
 
Posts: n/a
350 Odyssey

I've got a 350 odyssey and the problem lately is it runs good till about 1.2 throttle then acts more like a 4-cycle.
If I hunt around I can find a "sweet spot" on the throttle where it seems to run a little better but not much beyond 60% of full throttle. At higher rpms it kind of "Burps" back into the carb. Anyone have a clue how I fix this? Thanks !!!!!!!!
Sponsored Links
Advertisement
 
post #2 of (permalink) Old 09-11-2005, 03:29 PM
Apprentice
 
beekilla's Avatar
 
Join Date: Apr 2005
Location: North Wilkesboro, NC
Posts: 94
Thanks: 0
Thanked 0 Times in 0 Posts
 
Re: 350 Odyssey

Check your plug to see how you're "burning". Look at the tip of the plug. Black means you're rich. Grey or white means you're lean. Tan means you're perfect. I suspect you may be burning lean, judging by your description. Also, check your air filter and compression. Let us know what you come up with...[img]/ubbthreads/images/graemlins/cool.gif[/img]
beekilla is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Off-Road Forums & Discussion Groups forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome