banshee lost low end - Off-Road Forums & Discussion Groups
ATV Lounge Everything ATV - NOT defined in a specific forum below. Hang out with your friends.

 
LinkBack Thread Tools Display Modes
post #1 of (permalink) Old 07-31-2005, 08:39 PM
banshee9708
Guest
 
Posts: n/a
banshee lost low end

hey ,
my banshee has lost its low end.
it takes it forever to gain top rpms
, and u got to hit the throttle acouple of times
just to get it to hit the powerband

If u can help please do cause i dont know
what it is .thanks.
Sponsored Links
Advertisement
 
post #2 of (permalink) Old 08-03-2005, 07:45 PM
Apprentice
 
beekilla's Avatar
 
Join Date: Apr 2005
Location: North Wilkesboro, NC
Posts: 94
Thanks: 0
Thanked 0 Times in 0 Posts
 
Re: banshee lost low end

Check the compression. You should have well over 100 psi. If it is at all low, replace the top end before you do cylinder damage (and then it costs a lot more...). Check your air filter and then plugs. If the plug tips are grey or white, then you have some sort of fuel problem. If they are black, make sure that the air filters clean. Let us know what you find...more info gives a direction to go. [img]/ubbthreads/images/graemlins/cool.gif[/img]
beekilla is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Off-Road Forums & Discussion Groups forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome